Quick Sign In:  

Forum: VirtualDJ Technical Support

Topic: Beatsource songs not loading..
soulkutzPRO SubscriberMember since 2021
Ive been using VDJ with automatic updates for a few years now with Beatsource and have never had an issue. However, recently neither deck will load songs from beat source anymore. It'll download the cover and that's it. the actual song never downloads and appears in deck. Tidal is still loading fine. Beatsource is still loading correctly in Serato just not in vdi. any help will be greatly appreciated.
 

Posted Mon 01 Aug 22 @ 1:48 am
im having the same prob with SoundCloud
 

Posted 7 days ago @ 7:27 pm
Same issue with Beatport Link. Songs either do not load or load partially. I have to put a ton of songs into my decks mid set to figure out what will load and what won't and hope it happens before the current song drops out. Really frustrating.
 

Posted 6 days ago @ 3:23 am
soulkutzPRO SubscriberMember since 2021
So no solutions to this? I’m going to assume it’s probably something simple such as deleting a txt file from a directory but I can’t find a folder for beatsource within virtual dj in order to do so. Any help or solutions to these issues would be greatly appreciated. I have had to use serato again the last few gigs and I’d like to not have to be doing that.
 

Posted 4 days ago @ 2:27 am
Dj CiMiXPRO SubscriberMember since 2020
 

Posted 4 days ago @ 4:08 am
user23320751 wrote :
So no solutions to this? I’m going to assume it’s probably something simple such as deleting a txt file from a directory but I can’t find a folder for beatsource within virtual dj in order to do so. Any help or solutions to these issues would be greatly appreciated. I have had to use serato again the last few gigs and I’d like to not have to be doing that.


My guess is that there is not a lot of response because there is no general issue

I'm not signed up for beatsource, but I just tested 10 random songs with "it's sister" beatport, and they fully load, and work fine:

 

Posted 4 days ago @ 9:52 am
user25355300 wrote :
Same issue with Beatport Link. Songs either do not load or load partially. I have to put a ton of songs into my decks mid set to figure out what will load and what won't and hope it happens before the current song drops out. Really frustrating.

See above
I can't get anything to not load from Beatport
Tested 10 random songs in a row
 

Posted 4 days ago @ 9:54 am
Dj CiMiXPRO SubscriberMember since 2020
Here's a pictures of my previous issue, i play tonight long session, let see if issue gone.

 

Posted 4 days ago @ 12:50 pm
soulkutzPRO SubscriberMember since 2021
That’s exactly what mine is doing.. what did you end up deleting in files to fix it)
 

Posted 3 days ago @ 10:34 pm
See post #5 further up the thread.
 

Posted 3 days ago @ 2:43 pm
soulkutzPRO SubscriberMember since 2021
Welllllll… I deleted the settings file and it worked for a total of 3 songs & then started doing the same thing. It’s at the point that I’m bout to just give up & go back to serato unfortunately, which sucks cuz dj has so many more features but this is a major problem I can’t seem to solve. It just happened outta nowhere too.. I give up.
 

Posted 2 days ago @ 11:08 am
Based on earlier posts, it's got to be something specific to your setup, or to how you're using the Beatsource files. It works fine for others (Klaus for example).

It would also help if you gave info on exactly which tracks and/or playlist this is happening with. Perhaps it's just the ones you're using, and Klaus used other tracks.

When you tried with Serato and it worked, was that with tracks that failed to load in VDJ?

Sometimes these streaming services mess with the code at their end and it affects some things and not others. For example Tidal did something recently that affected Denon hardware only.
 

Posted 2 days ago @ 3:42 pm
soulkutzPRO SubscriberMember since 2021
I’ve chatted with beatsource and they claim it’s an issue with vdj. As far as what works and what doesn’t. Everything from beatsource still works with serato. And if I delete the settings file for vdj it’ll load two songs (doesn’t matter which ones) from beatsource and then stops loading anything further. I don’t use my MacBook for anything besides djing. I haven’t changed anything recently aside from updating virtual dj when it says it’s ready to. I see there are a few posts on this forum with ppl dealing with the same issue as myself when it comes to online sources.. so it’s not just a beatsource issue since some are having the same exact issue with tidal, SoundCloud and beatport. I was just hoping that someone who had dealt with this kind of thing would have a solution to it.
 

Posted yesterday @ 10:43 pm
Dj CiMiXPRO SubscriberMember since 2020
I'll make over hour playing session last friday (beatport), not problems this time. I'll be back if any problems came up again.
 

Posted yesterday @ 5:27 am
AdionPRO InfinityCTOMember since 2006
user23320751 wrote :
Welllllll… I deleted the settings file and it worked for a total of 3 songs & then started doing the same thing. It’s at the point that I’m bout to just give up & go back to serato unfortunately, which sucks cuz dj has so many more features but this is a major problem I can’t seem to solve. It just happened outta nowhere too.. I give up.

Did you delete the VirtualDJ\Documents\Cache\Beatsource folder?
 

Posted yesterday @ 5:38 am
soulkutzPRO SubscriberMember since 2021
Yeah I’ve deleted cache multiple times. I’ve uninstalled vdj and reinstalled and so forth. What I have found is that if I delete a u.txt file within the beatsource file that self generates, it’ll let me load 2-4 songs upon restarting vdj but then after that it stops again. 🤷🏻‍♂️
 

Posted 10 hours ago
gramseyPRO SubscriberMember since 2021
I'm having this exact same problem. I can load 1 to 3 songs from Beatsource, and then it stops working completely.

If I restart VirtualDJ, it will work again, but then will only load 1 to 3 songs from Beatsource. I just see "Opening Deck 1 / Opening Deck 2".
 

Posted 25 minutes ago