Quick Sign In:  

Forum: General Discussion

Topic: Early Access 7059
bogartPRO InfinityMember since 2004
Since update of version 7059 I keep getting a pop up saying unable to
create database backup.
I tried to restore back up from previous days. That did not work.
Reverted back to VDJ Version 6732 and working again.
I then accepted the update to 7059 again get the message.
Is there a possible bug in the early access 7059?
 

Posted 5 days ago @ 5:20 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
You have set some value (in days) for automaticDatabaseBackupPeriod ?
Which folder have you selected for DatabaseBackupLocation ? Does it have Write -permissions ?

 

Posted 4 days ago @ 1:10 am
bogartPRO InfinityMember since 2004
Have not changed anything. Since I rolled back it all works; but if I update it happens all over again
Backup is in VirtualDJ backup folder. Also backup period is set to 1. I now noticed that my laptop now does not have the backup folder.
 

Posted 4 days ago @ 12:01 pm
He didn't ask if you'd changed anything. He asked a specific set of questions, which you haven't answered.

What do you have set as your automaticDatabaseBackupPeriod?

What do you have set as your databaseBackupLocation?

Are those settings the same in 7059 as they are in the working rolled back version?
 

Posted 4 days ago @ 12:12 pm
bogartPRO InfinityMember since 2004
Backup period 1
Location is blank, I never touched this. Should it be set to location?
Did not check the backup options in 7059 because I did not change anything.
Also now when I play a song, I get a pop up saying Disk D: full. There is over 1/2 free space left.
 

Posted 4 days ago @ 12:23 pm
bogart wrote :
Should it be set to location?


Really you shouldn't need to be asking that question!

Put a location in, then report back. Hopefully that will solve the issue.

By the way, when you said the rolled back version was working, do you mean it was creating a backup, or just that there was no popup?

IMO having a popup telling you that it can't create a backup (because you've not set a location) is an improvement, not a bug.



 

Posted 4 days ago @ 12:46 pm
bogartPRO InfinityMember since 2004
When I rolled back it made a backup.
Updated to 7059. entered backup location
D:\Users\Owner\Documents\VirtualDJ\Backup.
It does not save the setting.
Permissions are all good. Still shows drive full when loaded a song.

 

Posted 4 days ago @ 2:23 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
bogart wrote :
Still shows drive full when loaded a song.

Can you post a screenshot of this error ?

What is Drive D: ? Not your OS Drive i suppose. An external/removable drive , an SSD ?

Also curious about the permissions of this folder .. D:\Users\Owner\Documents\VirtualDJ\Backup
You are the "Owner" user, with Admin rights ?
Does this folder exist , but empty ?

 

Posted 3 days ago @ 5:20 pm
bogartPRO InfinityMember since 2004
Desktop PC 2 drives. D: has music.
D:\Users\Owner\Documents\VirtualDJ\Backup Was not appearing in Options/backup/, however in my documents folder it was there. When I tried to input the backup folder, it would not save.
I finally deleted VDJ and reinstalled. Then I was able to input the backup location in options menu.So far it seems to be ok.
Also checked my laptop and found same problem(No backup folder) When I input the backup location, it saved and seems to be good.
Permissions were all set properly.
So far looks good.
Thanks
 

Posted 3 days ago @ 5:42 pm
bogartPRO InfinityMember since 2004
Spoke too soon.
Still getting unable to create database backup. Also Backup has folder etc.
 

Posted 3 days ago @ 5:51 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
If D has your Music, then where is VDJ installed ? Are you sure your Documents Folder is D:\Users\Owner\Documents and not C:\ ?
Anyways, not sure how your computer is structed, but to avoid the Auto Backup and keep you going with VDJ until you figure it out, you can set the automaticDatabaseBackupperiod to 0
 

Posted 3 days ago @ 6:01 pm
bogartPRO InfinityMember since 2004
VDJ installed on D:

 

Posted 3 days ago @ 6:09 pm
AdionPRO InfinityCTOMember since 2006
Your screenshot shows that the folder is read only for some reason, so that probably explains why vdj can't access the database
 

Posted 3 days ago @ 6:15 pm
bogartPRO InfinityMember since 2004
Adion wrote :
Your screenshot shows that the folder is read only for some reason, so that probably explains why vdj can't access the database


Just changed it and it still shows,"unable to create database backup"
 

Posted 3 days ago @ 6:27 pm
bogartPRO InfinityMember since 2004
bogart wrote :
Adion wrote :
Your screenshot shows that the folder is read only for some reason, so that probably explains why vdj can't access the database


Changed it previously. Just changed it again and it still shows,"unable to create database backup"Why won;t it accept changes



 

Posted 3 days ago @ 6:30 pm
bogartPRO InfinityMember since 2004
Still no luck. This is a desktop PC windows 10, which has 2 drives. C drive is main drive for programs. D is where music is stored ( as well as some word documents)
I fond the program is on C drive, however the folder containing all the shortcuts, mappers etc.is on the D drive. I had no problems until I updated to the early access 7059, that's when this all started.
I tried to move the to move the folder containing mappers, shortcuts onto the C drive in VDJ, but that did not work.
What about deleting VDJ completely and starting fresh? Is is there a way to do this and still keep all the mappers etc?
 

Posted yesterday @ 7:57 pm
Unless you specifically tell the registry otherways, VDJ should have it's home folder on C drive documents folder.

Maybe worth checking. I have my home folder on D but all my backups work fine, even on build 7059

[HKEY_CURRENT_USER\Software\VirtualDJ]
"HomeFolder"="D:\\VirtualDJ"

You can set where the VDJ folder is there. Unless you have a specific use case it should be in the dicuments>virtualDJ folder on C drive
 

Posted yesterday @ 8:03 pm
bogartPRO InfinityMember since 2004
@KRADCLIFFE:

D drive is:
C Drive:
Registry
 

Posted yesterday @ 9:28 pm
Probably best to find your proper Virtualdj home folder and move it to the C > users > documents folder and update the registry accordingly.
 

Posted yesterday @ 11:22 pm