Quick Sign In:  

Forum: VirtualDJ Technical Support

Topic: Sandbox bugs in 8.5-64 b6978
soenPRO SubscriberMember since 2022
Hi-
I've spotted two bugs in Sandbox mode and I've been able to reproduce them reliably:

Bug 1 - Sandbox causes track to jump backwards on first use:
1. Load track into deck A
2. Play track
3. Enter sandbox mode
4. Play for a little bit
5. Exit sandbox mode

The track in Deck A will jump backwards on the master output. This only happens on first use.

Bug 2 - Entering/exiting Sandbox mode causes volume to jump
1. Set master output volume to 50%
2. Load track into deck A
3. Begin recording master output
4. Play track
5. Enter sandbox mode
6. Play for a little bit
7. Exit sandbox mode
8. Stop recording

If you load the audio into an audio editor, you can see large volume changes when entering/exit sandbox mode.

I'm a software developer myself so happy to help out/diagnose any faults, for example, if it's environmental or hardware specific.

Thanks,
Soen
 

Posted 4 days ago @ 10:38 pm
AdionPRO InfinityCTOMember since 2006
Second bug found, but couldn't reproduce first one.
Did you use any effects or so while sandbox was active?
 

Posted 4 days ago @ 5:23 am
FYI: another very minor sandbox bug (still in build 7021) is Deck 1 continues to play in headphones after sandbox is turned off, for first use only, as reported here (and confirmed by another user):


http://www.virtualdj.com/forums/239677/VirtualDJ_Technical_Support/Reporting_a_possible_very_minor_bug__Sandbox_mode_and_headphone_audio_switching_for_Deck1.html

IIDEEJAYII wrote :
Reporting a possible very minor bug.

Let me try to explain the steps.

1) Start VDJ (Pro Skin have not tested w others)
2) click the highlighted blue PFL to turn it off
3) Load song on deck 1 and play track
4) Click sandbox mode and track is heard through headphones
5) Turn off sandbox mode .. headphones STILL PLAY AUDIO (with deck1's PFL button off)

the fix is to toggle deck 1's PFL button on and off,

Then sandbox mode audio is switched correctly, until the next time VDJ is restarted.


NOTE:
This works correctly from the start if Deck 2 is used first.

IE:
1) Start VDJ (Pro Skin have not tested w others)
2) click the highlighted blue PFL to turn it off
3) Load song on deck 2 and play track
4) Click sandbox mode and track is heard through headphones
5) Turn off sandbox mode and headphone audio is off as expected

and deck 1 will also function correctly, if Deck 2 is used first, until VDJ is restarted.
(without that toggle fix, which is needed for deck 1)


Summary:
Headphone audio does not turn off, when using Sandbox mode, after starting VDJ, when deck 1 is the first to use Sandbox mode.
Once PFL for deck 1 is toggled on and off after using sandbox mode, Sandbox mode audio works perfectly.
(Or if deck 2 uses Sandbox mode first)


I can create a video with audio.

no need to fix,
I am just reporting this possible minor bug.
--------------
VDJ ver 6294
Default Pro Skin
No controllers connected


 

Posted 4 days ago @ 5:58 am
soenPRO SubscriberMember since 2022
Adion wrote :
Second bug found, but couldn't reproduce first one.
Did you use any effects or so while sandbox was active?


Nope, no effects, just straight out of the box. It could be my ASUS U5 external soundcard (using ASIO - using 4 of the 6 channels, first two are headphones, second two are master) that needs some sort of extra initialisation. In terms of disruption, this one is relatively minor, the second bug kills my ability to record podcasts at 50% master volume to avoid clipping.
 

Posted 4 days ago @ 12:17 pm
soenPRO SubscriberMember since 2022
Just thinking, to aid diagnosis, I could route through Voicemeeter to see if that produces the same problem.
 

Posted 4 days ago @ 12:31 pm
soenPRO SubscriberMember since 2022
Just to confirm I was able to reproduce both these faults when using ASIO to Voicemeeter.
This happens both when Voicemeeter outputs to my external soundcard or internal soundcard.
I was able to reproduce bug 1 on direct WASAPI output from VDJ as well.
 

Posted 3 days ago @ 7:29 pm