Quick Sign In:  

Forum: VirtualDJ Technical Support

Topic: High end gaming laptop running out of sound buffer
Got a Lenovo Legion 7i a couple of months ago, i9 12th Gen, 32gb RAM, RTX3080Ti and the performance in general is great. Really fast for calculating stems in real time and rendering video etc.

There seems to be an issue where the sound stops after maybe 1, 2, 3 hours at a gig and I have to hit "apply" in the sound config to reset it. Starts off with the sound starting to crackle then it stops dead after maybe 10 seconds.

I thought it was the Denon ASIO drivers (which I previously used on my C940 with absolutely no issues) so I changed to WASAPI and it's doing exactly the same thing. Under ASIO I tried with ultra latency on and off and also changed the Denon control panel from 128 to 256 to 512 with no difference. I've done the same with WASAPI and it still does the same at 512 samples which it shouldn't on such a fast laptop.

There don't appear to be any system warnings, and although the latency monitor doesn't paste a perfect picture (it never does with these gaming laptops) it doesn't appear there's a relationship between the spikes and the sound cutting out.

Anyone have any ideas before I stop using it and go back to precomputing stems and using the C940 again?

Posted Sat 08 Apr 23 @ 12:16 am
I have the Same Problem,
Legion 16 i5 16gb DDR5 all in internal m.2
RTX 3060
And Prime 4
Win 11 latest and VDJ Early
After a few hours the Sound get noise, and bits, also over the Headphones.
Most time over the right Deck i think.
Have to Test IT this evening in the Club.

I read to Set Latency Up to 1500 in another Post. Bit If i Switch this Settings of the Quality in the Denon driver, VDJ is Crashing and have to restartand losing all changes.

Posted Fri 14 Apr 23 @ 5:26 am
Yes if you change the setting in Denon control panel while VDJ is open then it crashes. 1500 is a very high setting.

I've done a bit of tweaking and will try again tonight.

Could be a Windows 11 issue as I've read of others having similar issues, however this laptop can't be downgraded to 10 I don't think.

Posted Fri 14 Apr 23 @ 7:15 am
The next Option i read ist a USB Drive with Problems.
I Hope there is a fix.

Posted Fri 14 Apr 23 @ 7:20 am
Are you both running the OS that came with the laptop or did you carry a clean install to get rid of all the bloatware?

Reason I say this is, when i first used my new Dell laptop (yes they are terrible for bloatware) i found a number of scheduled tasks which were doing various things after 2 hrs of the laptop being on and it caused me performance issues similar to what you are experiencing.

So might be worth checking for any scheduled tasks.

Another thing i have done is created a local group policy to prevent windows updates. Yes you can set to pause them in the OS but it doesn't stop the check in happening.

Worth a shot.

Posted Fri 14 Apr 23 @ 8:11 am
I did have a look in the task manager but will do another dig down. Not done a clean install yet as it takes a while to do.

It only has Windows 11 home at the mo so can't access group policy editor but I'm planning to upgrade to a Pro key soon.


Posted Fri 14 Apr 23 @ 9:18 am

Posted Fri 14 Apr 23 @ 10:52 am
The problem sounds very similair I had for years ago when using a Denon MCX8000 with a USB3 ports not able to sustain the speed. It, just as you describe, could work for quite a while and then start to crackle more and more until silent.
If memory serves me right, I was not able to hit apply again to resume.
By switching to a USB2 port solved my issue.
I have no idea if this is anywhere related but still wanted to inform.

Posted Fri 14 Apr 23 @ 11:34 am
I'm running it through a hub from a thunderbolt port. Worked fine on my previous Lenovo. I can try one of the USB A ports and see what happens. Thanks for the tip.

Posted Fri 14 Apr 23 @ 12:48 pm
This might not apply to this situation, but I had all types of problems with win11 and RTX3060. Removing all the nvidia software and only using the driver cleared most of my problems. A few tweaks cleared the rest which had to do with stems.

Posted Fri 14 Apr 23 @ 3:37 pm
Djratedxxx919 wrote :
This might not apply to this situation, but I had all types of problems with win11 and RTX3060. Removing all the nvidia software and only using the driver cleared most of my problems. A few tweaks cleared the rest which had to do with stems.

There was a issue with a recent version using a lot of CPU that has been resolved. With current drivers .... Sounds like what you experienced


Posted Fri 14 Apr 23 @ 3:45 pm
Thanks for the info. I did uninstall all the nvidia crap and just have the driver but I never knew there was a new one.

That may explain why the CPU temp was going up when VDJ was running as it activates the RTX3080ti on load.

Have just downloaded and installed it so see how it goes tonight.

Posted Fri 14 Apr 23 @ 4:01 pm
Just to add the tweak I did in VDJ, I set the video driver to the system video, mine is the Intel UHD graphics. In the stems video driver, I set to use the RTX3060. Everything seems to have been fixed. No problems, the stems take 2 or 3 seconds.

Posted Fri 14 Apr 23 @ 4:44 pm
I had that option selected anyway but recently changed it back to use the RTX. With the 3080Ti the difference using it for all VDJ functions would be minimal anyway I guess.

Posted Fri 14 Apr 23 @ 5:22 pm
Just a wee update. I tried installing Windows 10 to see if the latency would be better (which it was) but then coincidentally the thunderbolt ports completely failed. Engineer came and fitted a new motherboard then the keyboard lighting wouldn't pick up the UK mapping so it wouldn't work properly. He also didn't do a good job of repasting so that would have led to issues further down the line too.

Lenovo support were utterly useless so I have finally managed to get a RMA from my supplier who will issue a refund.

Back to the reliable C940 from 2019 that just works. I will just precompute the stems on my home machine then sync them over instead.

Posted 2 days ago @ 12:26 pm