Quick Sign In:  

Forum: General Discussion

Topic: feature? bug? is it me? (mouse pointer over search field)
When I move the mouse pointer over the search field in the browser section, the mouse pointer itself disappears so I can't see where I'm clicking to place the cursor (for example to fix a mistyped character or word).

Also, trying to double click a word (again to replace a word I mistyped) selects the whole field not just one word.

Is this how it's supposed to be, or is my system misconfigured?

Posted Thu 09 Mar 23 @ 12:04 am
Moving the cursor over the searchbox changes it fron an arrow (pointer) to carret. That's typical behavior for textboxes on all windows software. So, yes, that's the expected behavior. Depending on the skin you use it may be easier or harder to see the carret as typically it will be black or white (windows determine this automatically, and choose whatever will provide most contrast)
As for double clicking, while it's more common to double click in order to select a word and triple click to select a sentence in most software, VirtualDJ selects all the contents on double click instead. The idea behind it is to provide a quick way to initiate a new search while you are allready in a search.
Personally I'm not in favor of one way over another.
However it's not a bug. It operates as it should.

Posted Thu 09 Mar 23 @ 10:38 am
Interesting - I am using the default skin in Pro mode. I tried switching to the other modes, and the only one where a caret appears is Starter, the rest cause it to disappear - and I mean disappear entirely, it's not that the contrast is low, it's completely invisible.

When it's there in Starter mode, it's very clear to see, even if I move it slightly so part is over the black internal section and part of it overlaps the border of the textbox, it's still quite visible and clear.

It doesn't seem like the color pallette changes between Starter and the rest in the default skin. So it seems surprising that the caret behavior is different?

Double-click - got it. I can live with that.

Posted Thu 09 Mar 23 @ 12:21 pm
So is there a specific way to report this issue? I do believe it's a bug and though it may seem minor it's really throwing me off, not being able to see the caret as I move it makes it near impossible to edit values in the search field.

Posted Fri 10 Mar 23 @ 11:18 pm
Do a quick test:
Try to change the "toolTip" setting.
Does it make any difference ?

Posted Tue 14 Mar 23 @ 11:25 am
Hey - just tried all three settings - yes, no, value-only - sadly the same behavior happens with all three.

Posted Tue 14 Mar 23 @ 5:16 pm
No problem with cursor...works fine

"Also, trying to double click a word (again to replace a word I mistyped) selects the whole field not just one word."
here also...

Posted Tue 14 Mar 23 @ 6:15 pm