Quick Sign In:  

Forum: VirtualDJ Technical Support

Topic: Master deck selection keeps breaking
mpuschPRO InfinityMember since 2011
Every time I use virtual DJ, I will eventually come to a song that will NOT allow me to set the song's tempo as the master, even if it is the only song playing / the crossfader is fully to the playing deck. After that i wont be able to set any song loaded in that deck as master until restarting the program.

This is a CRITICAL, PROGRAM BREAKING, SET ENDING problem - really glad I dont currently have a licence or i would be extremely upset.

PS - in advance, the answer to this problem is NOT telling me how to beatmatch :)


Posted Mon 27 Feb 23 @ 2:06 am
AdionPRO InfinityCTOMember since 2006
What do you mean exactly? What exactly is not allowed, what do you press, what's happening and what do you expect to happen?

Posted Mon 27 Feb 23 @ 4:26 am
mpuschPRO InfinityMember since 2011

So when playing two tracks, i am clicking on the MASTERDECK buttons shown above. generally if the crossfader is centered, there is no issue switching which deck is currently set as master.

The issue is occasionally the MASTERDECK button will stop working entirely for a single deck until the program is restarted - the GUI will just show it as unselected, and clicking the button will not enable master no matter what, even if that is the only track playing. (note - clicking master WILL enable cueing for the selected track, but doesn't select the track as master).

In addition to ruining bpm syncing, this breaks all my filters as they require master information to update.

any advice would be appreciated (although technically I think this is just a bug with no help possible)

Posted Mon 27 Feb 23 @ 4:33 pm
Bumping this one, coz i have the same issue using a denon MCX8000. in the middle of the set masterdeck goes off, and crazy things start to happen when trying to sync, sometimes the playing track speeds up when trying to even manually beatmatch. almost like beatlock comes on or something. after that there is no way to get masterdeck to work as intended.

Posted 2 days ago @ 2:07 pm
I had this similar issue before, and this is something I had found out that may be helpful (or not) here:

  1. There is a difference between the master deck and active deck

    • Active Deck normally seems to follow the active sound (which normally follows the crossfader direction) - it only seems to switch when the active sound is completely to one deck and it is audible.
    • Master Deck really control what the sync of other decks and other things (like filter buttons based on range) use as their guide

  2. (Normally) Master deck automatically follows the Active Deck
  3. (Most Importantly) If you manually click on the Master option for a deck, it overrides the automatic following logic and leaves that deck as the Master deck

To reset the logic to 2), you have to right click on the Master option for that same deck.

Try right-clicking the Master button of the affected deck and then going through a sequence of track loads to see if it resolves your issue.

Posted yesterday @ 1:03 am