Quick Sign In:  

Forum: VirtualDJ Technical Support

Topic: Stems volume on fader - top of fader is too loud/distorting?
Hi,

Think I've found a slight bug with Stems and using faders to control the volume of individual stems and was wondering if someone can test to make sure it's not just me having problems!

I've assigned a fader on my AKAI APM Mini to 'deck left stem "Rhythm"' to control the volume of the rhythm stem. I'm also using the 'EZ Remix' option so this is also assigned to the bottom EQ knob on the mixer. If I turn the bottom EQ knob down, and the back up, the rhythm stem fades in and out and returns to the same volume as before.
However, if I use the fader on my APC Mini to do the same thing, the rhythm volume comes back in louder than it did before and is also a little distorted. The VU meter on the channel is also peaking higher than before so I know it's not just my ears!
If I then use the EQ knob to turn the rhythm down and back up, it returns to the volume it was before I used the APC Mini fader.

I also have Vocal/Intru/Bass assigned to faders on my APC Mini and they do the same thing. It's almost as if assigning the 'deck left stem Vocal/Instru/Bass/Rhythm' to a fader, and then bringing it up to the top is making it go over 100%? The fader range is 0-200% or something? I can't figure it out. If I bring the fader just halfway up it seems to match the volume of what it was previously but I can't be totally sure that that is the case.

Any help would be greatly appreciated.

Thanks!
 

Posted 7 days ago @ 7:42 pm
You're not the first person to mention this, but what you have to bear in mind is that on the EQ knobs (where stems are normally mapped) the centre 50% position is the default level, not 100%.
 

Posted 7 days ago @ 8:11 pm
But moving the fader mapped to 'deck left stem "Rhythm"' doesn't move the EQ knob on the screen at all? It seems like mapping the stems directly is totally separate to the EQ's. Even if it did, moving the EQ knob to 100% would isolate that stem (muting all the others) rather than doubling the volume?

As a workaround, is there a way to make my fader just use 50% of the range instead of the full range? So at the top of the fader is 50% and the bottom is 0%?

EDIT: I just found this post with someone who is having same issue: https://www.virtualdj.com/forums/249740/VirtualDJ_Technical_Support/BUG_REPORT__Stems_mapping_to_a_pot___slider_distortion_over_50_.html

As a workaround I have changed the script to have param_multiply 0.5 & infront of the current stem mapping, so 'param_multiply 0.5 & deck right stem "Rhythm"' for the rhythm and now it works as I expect it to.

Thanks
 

Posted 7 days ago @ 8:32 pm
Manipulating stem 'Rhtyhm' will not move the EQ knob on the skin because the EQ knob does a mixture of functions. To put it otherwise, EQ knob under certain circumstances will manipulate stem 'Rhythm'. The opossite is not true (not a 2 way communication between script actions)
 

Posted 6 days ago @ 10:35 am
djdadPRO InfinityDevelopment ManagerMember since 2005
DJNemobob wrote :
As a workaround I have changed the script to have param_multiply 0.5 & infront of the current stem mapping, so 'param_multiply 0.5 & deck right stem "Rhythm"' for the rhythm and now it works as I expect it to.


Exactly, this is the currently working way, not a workaround

 

Posted 6 days ago @ 12:32 pm
PhantomDeejay wrote :
Manipulating stem 'Rhtyhm' will not move the EQ knob on the skin because the EQ knob does a mixture of functions. To put it otherwise, EQ knob under certain circumstances will manipulate stem 'Rhythm'. The opossite is not true (not a 2 way communication between script actions)


That's fine, and is what I would expect seeing as the EQ knob has the isolate function as well.

What doesn't make sense is why assigning stem 'Rhythm' to a fader/knob, and then moving the fader/knob to 0% and then back to 100% would make the volume of the stem louder than it was originally (50% fader/knob seems to return the stem volume to normal). Seems as if setting the fader/knob to 100% is actually pushing the stem volume up to 200%. Logic to me would dictate that the stem should never be able to go above 100% volume regardless of what is done to it.
 

Posted 6 days ago @ 12:32 pm
DJNemobob wrote :
What doesn't make sense is why assigning stem 'Rhythm' to a fader/knob, and then moving the fader/knob to 0% and then back to 100% would make the volume of the stem louder than it was originally (50% fader/knob seems to return the stem volume to normal). Seems as if setting the fader/knob to 100% is actually pushing the stem volume up to 200%.


I am the one that created the other post you linked to, but you just described it way better than I originally did ;-) That's why I said I've configured my sliders "param_multiply 0.5" as a "workaround", because I think it is what it is. I understand everyone stating the Stems behaving like EQ's, but it's not really that way. Stems values are +/- 100%, while EQ's are not... I won't be overdriving Mids (nor hit the limiter) if I put that MID EQ potentiometer to the max (+6dB) but I WILL badly overdrive the Stem if I map any Stem to that same control.

I recently purchased a small Korg nanoKONTROL2 (8 tiny sliders) that I've mapped for that same purpose, and I also had to do the same (param_multiply 0.5) to make it work 0-100%, instead of 0-200%, and prevent overdriving everything that's above 50% as you described:

<map value="SLIDER_1" action="deck 1 param_multiply 0.5 & stem "rhythm""/>
<map value="SLIDER_2" action="deck 1 param_multiply 0.5 & stem "bass""/>
<map value="SLIDER_3" action="deck 1 param_multiply 0.5 & stem "instru""/>
<map value="SLIDER_4" action="deck 1 param_multiply 0.5 & stem "vocal""/>
<map value="SLIDER_5" action="deck 2 param_multiply 0.5 & stem "rhythm""/>
<map value="SLIDER_6" action="deck 2 param_multiply 0.5 & stem "bass""/>
<map value="SLIDER_7" action="deck 2 param_multiply 0.5 & stem "instru""/>
<map value="SLIDER_8" action="deck 2 param_multiply 0.5 & stem "vocal""/>

Everything works wonders that way, but I just needed a couple minutes (beers) to figure it out ;-)
 

Posted 6 days ago @ 9:58 pm