Quick Sign In:  

Forum: VirtualDJ Technical Support

Topic: Virtual DJ and Wireless Display freeze if lost connexion.
Good morning!
Sorry for my English,

I have been using the Wireless Display option (Microsoft Miracast) for some time.

However, since some time, VirtualDJ freezes completely if I lose connection with the TV. I have to kill it and I also lose the history of the songs play.

The problem is present on 2 different laptops. Win10 and win11, AMD vs Intel etc.
The problem does not seem to be present if the laptop is connected to an external screen + the Wireless Display

Thank you all if you have an idea to fix this problem.
I haven't tried an HDMI emulator...that's my next step.

Posted Mon 21 Nov 22 @ 12:14 am
Some Update,

I did other tests, the problem is easy to reproduce, just cut the wifi card (turn off) while the video is sent to the external screen in miracast wireless display so that virtualDJ freezes completely.

I specify that the audio is sent on an external USB card and not on the TV

If I connect a 3rd screen in duplications (Portable screen + 27 inch screen) and the 3rd screen (TV) in Wireless display for the video only, if I cut the wifi to simulate the failure, VirtualDJ I do not freeze and transfer the video to the main screen and I can minimize it, etc.

thank you :)

Posted Mon 21 Nov 22 @ 2:49 am
I tried a new out of the box laptop Dell Vostro 7620, i7-12700h with RTX3050 at the office today and I have the same problem as with my older laptops at home.


Posted Mon 21 Nov 22 @ 7:52 pm

2023 early version have the same problem ... :(

Posted Thu 24 Nov 22 @ 1:49 am

not having had any response from support in private as well as on the forum, I believe I have found a workaround

It seems to have a problem with Nvidia GTX/RTX

Unfortunately, virtualdj had to be forced to use the integrated Intel GPU for video.

I'm going to do more tests but so far it seems to work...

2. Change GPU Preference for Miracast

2.1 go to the under left Windows Logo on your desktop and press the right mouse button while you´re hovering over it

2.2 Select "Settings"

2.3 go to "System"

2.4 now select "Display" as the active Option

2.5 choose your Monitor / Display you want to Miracast

2.6 scroll down to the "Graphic Settings"

2.7 in the new Window choose in the first drop Down Menu and select "Universal App"

2.8 Now Choose "Connect" as the preferred Application in the second drop down menu

2.9 add the Application

2.10 Now lets go to "Settings"

2.11 Choose your preference to " energy saving " -> " Intel UHD XXX " ( XXX is the Intel GPU graphic your system have) OR the Intel GPU the system shows you

2.12 Now you could use miracast again becouse your Intel GPU provides Miracast Support and skips your NVIDIA GPU as the primary GPU for this process in WIndows 10

Posted Thu 24 Nov 22 @ 3:16 pm