Quick Sign In:  

Forum: VirtualDJ Technical Support

Topic: Beatport Link truncates waveforms on timeline if you load tracks simultaneously Build 6978
This behaviour is recreatable on my setup and several of my clients setups for whom i provide technical support.

So when I load a track from Beatport Link on deck 1 and then quickly load another beatport link track on deck 2 while deck one is still drawing waveforms, deck ones wave is truncated and upon playback audio stops at the same point. Doing this repeatedly causes the Beatport Link functionality to cease completely.

I have also been having problems with Beatport Link previews in the info section recently and I believe the two are related.

This behaviour does not occur with local files or Tidal streaming only when using the Beatport Link API

I have gone back to Build 6800 and Beatport functions perfectly (and loads tracks much much quicker)

Might be worth looking at..

Regards

-Alx
 

Posted Wed 15 Jun 22 @ 8:25 pm
Had exactly the same issues after last update ! Had tracks not fully loading I have done as you suggested and it has fixed the issue much appreciated thanks for your assistance I think VDJ need to look at this for the next update! Well done with the fix!! Well done!
 

Posted Wed 15 Jun 22 @ 10:19 pm
you are welcome.

This is clearly an issue with the Beatport API integration in more recent builds.
 

Posted Wed 15 Jun 22 @ 10:28 pm
soenPRO SubscriberMember since 2022
I gave up with Beatport after a track wouldn't load mid-set. Can't have that happen! Not to mention their website is slow as heck. I cancelled my Beatport subscription and told them to upgrade their servers.
 

Posted 4 days ago @ 10:48 pm