Quick Sign In:  

Forum: VirtualDJ Technical Support

Topic: NEW UPDATE (v8.5-64 b6503) MESSED UP MY K2 MAPPERS !!!
Hello,

I've updated to latest VDJ version (v8.5-64 b6503) and all my customized mappers for my Xone K2 have become useless. Can you tell me what's wrong?
It seems that now VDJ recognizes all the K2 buttons differently (I've tried using the 'factory default' to notice that all the commands and buttons have changed their names). I hope this is a bug and to be fixed soon enough!

I expect some feedback on this matter, please.
Thanks
 

Posted Wed 09 Jun 21 @ 11:11 am
If you had a custom mapper, it should still be there in the drop down at top right corner in the mapper settings in the software. Did you also have a custom definition file?

As for the default factory mapping see here:
https://www.virtualdj.com/manuals/hardware/allenheath/k2/setup.html

There was two A&H mixers added recently, but not sure if the K2 definition files changed in that regards.
But will check and ask the guys mapping it ;-)
 

Posted Wed 09 Jun 21 @ 11:19 am
Yes, it seems with this new build (b6503) that they have changed the definitions for the buttons of my K2 (and many of them are simply MISSING).

I've had my custom mapping for years now without any problem.

Now, when I choose to use my custom mapper, the button list read like this:


But when I change to 'factory default' it seems that all commands and buttons have now a different name.



Any solution to this? Even if I had to map all over again, many of the functions and buttons featured on my K2 seems to have been erased from VDJ.
 

Posted Wed 09 Jun 21 @ 11:30 am
Hello, thanks for your reply.

It is actually a shame you had to change the K2 mappings for good.
I wouldn't mind coming up with a new mapping matching the old definitions with the new, but I've tried that yesterday and it seems that many of the former features / button names / functions are now gone ...

Since I can't currently afford a PRO version (plus I've already spent 99 usd on my K2 license), I'd be happy to send you my custom mappings to see if you can make them work with this new setting... that would be really appreciated.

I'm sending you an email.

Thanks for your feedback and I hope we can sort this out.
 

Posted Thu 10 Jun 21 @ 9:10 am
Hi! I'm having this exact same issue and I was wondering where could I get the old definition file or if this will be sorted out any other way. Thanks in advance!
 

Posted 2 days ago @ 3:48 pm