Quick Sign In:  

Forum: VirtualDJ Technical Support

Topic: Pioneer DDJ-SX2 - Timecode Inputs
djdadPRO InfinityDevelopment ManagerMember since 2005
As of Builds 4189, the Inputs of the Pioneer DDJ-SX2 can be used for Timecode/Line inputs in VirtualDJ.
For those who wish to test, Build 4189 is currently in Early Access, so you will have to enable the EarlyAccessUpdates setting from VirtualDJ Options and restart, to automatically update to the EA Build.

The sound card of the DDJ-SX2 should be now offered as 2IN/2OUT and 2 stereo inputs should be available to use as Timecode or LineIn inputs.

 

Posted Thu 15 Mar 18 @ 5:10 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
 Best Answer As of Builds 4209 the DDJ-SX2 can now offer Timecode inputs

The new mapping* files now offer a DDJSX2 DVS Pad page, which can be selected from the Pads of VDJ GUI and offer DVS ON/OFF Pads 1 and 2 to set the unit to either the "Controller" mode or the "DVS" mode. When the DVS mode is enabled, 2 additional Pads (3 and 4) are offered to select the DVS Input types.

* requires the factory default mapping to be chosen from Controllers tab


Some useful notes...
- Each time the controller mode is changed, you will need to visit the Audio setup, click on the Pioneer DDJ-SX2 special button at the top and then click on APPLY.
If you wish to have an automation, so that the Audio setup is applied automatically each time you use Pads 1 or 2 (or the unit gets connected to VirtualDJ), open VirtualDJ Settings-->OPTIONS tab and set the ControllerNotification setting to !DDJSX2, Doing this, you will be getting a detection window on each re-connection and you will need to click on the "Use Sound card" button to apply the pre-defined Audio setup for each case.

- The Controller mode offers a single Input which is used to record your mix along with the Microphone and AUX inputs.

- The DVS mode turns the sound card of the DDJ-SX2 into 2IN2OUT and the 2 Input Channels are used for Timecode (or LineIn). There is no special record input in this mode, so the REC within VirtualDJ will only record your mix and not MIC or other analog sources.

- The sound card in "Controller" mode is 24 bit, while the one in DVS mode is 16-bit

- You cant have one Input as LINE and the other as PHONO. Due to firmware limitation, both inputs need to be set to the same type.

- If you wish not to get the Detection window when modes are changed or on every unit re-connection, set the ControllerNotification setting to DDJSX2


We have tested on both Mac and Windows and was working well during our tests, but would appreciate further feedback.



Note that the mode switches require the factory default mapping to be used. In case you need this feature (to switch to DVS), and still use your Custom mapping, you can add the following lines to your/Mappers/ Custom xml file
<map value="DNC_DVS_ENABLE" action="var_equal '@$sx2_dvs' 1" />
<map value="DNC_DVS_DISABLE" action="var_equal '@$sx2_dvs' 0" />
<map value="DNC_DVS_PHONO_S1" action="var_equal '@$sx2_dvs_phono' 1" />
<map value="DNC_DVS_PHONO_S2" action="var_equal '@$sx2_dvs_phono' 1" />
<map value="DNC_DVS_PHONO2" action="var_equal '@$sx2_dvs_phono' 1" />
<map value="DNC_DVS_PHONO1" action="var_equal '@$sx2_dvs_phono' 1" />
<map value="DNC_DVS_LINE_S1" action="var_equal '@$sx2_dvs_phono' 0" />
<map value="DNC_DVS_LINE_S2" action="var_equal '@$sx2_dvs_phono' 0" />
<map value="DNC_DVS_LINE2" action="var_equal '@$sx2_dvs_phono' 0" />
<map value="DNC_DVS_LINE1" action="var_equal '@$sx2_dvs_phono' 0" />

Posted Wed 21 Mar 18 @ 6:41 pm[ selected best answer by djdad on Wed 21 Mar 18 @ 6:47 pm ]
I ran across a few issues testing the DDJ-SX2 for timecode use in VDJ 8.2 early access pc build 4189.1405 while using the default mapping.
The most reliable solution I have found is at the end of this post.

It seems the only way to receive timecode signal input directly from my turntable using ASIO is to flip a hardware input select switch to phono. I can see changes when the hardware input selector is set to pc/line however they seem to be out of the range for calibration. Using WASAPI the timecode signal input is strong on all three input selector settings but results in a bad signal which is not clean enough to calibrate.

When switching the input select switch to phono the virtual deck is muted and VDJ audio output stops, however timecode signal noise is output to booth/master.
When using a separate output in VDJ settings such as an audio interface or laptop speakers to avoid the timecode signal noise, the virtual deck remains muted and no audio is heard. The virtual deck also remains muted when the DDJ-SX2 is switched to standby preventing output to other devices.

When switching the input select switch to phono some controls are disabled in the default mapping because of the hwmixer variable preventing those controls from being changed using the hardware while the timecode is in use.

In order to resume virtual deck/VDJ audio output and hardware controls the deck must be unmuted and the hwmixer variable reversed.
Switching the input select to PC then changing the input_select mapping to nothing is a temporary fix to resolve this, however a more complicated mapping should be used to identify each decks use so that other line/mic input use, such as deck 3 and 4, are not disturbed when using timecode with the input selector on phono.

This however creates another issue where both the virtual deck/VDJ audio out AND timecode signal noise is heard at the same time, which is not desired. This also has a temporary fix at the cost of being unable to use the hardware channel fader. By setting the hardware channel fader to the minimum/down the timecode signal noise is removed/reduced and the software channel fader can be increased, outputing the virtual deck/VDJ audio to the booth/master out directly. This means that you can hear the virtual deck/VDJ audio without hearing the timecode signal noise, but cannot use the channel fader for this channel.

I also noticed the following while both timecode signal noise and virtual deck/VDJ audio are audible; Switching the input select switch from phono to PC stops the timecode signal noise as expected, however when switching from PC back to phono there is a short time period when only virtual deck/VDJ audio is heard before the timecode signal noise returns and both timecode signal noise and virtual deck/VDJ audio are audible again.

Another solution to avoid these issues is to use a phono preamp. This provides a strong enough timecode signal for Virtual DJ to run its calibration and enable timecode use even while the hardware input selector is set to PC and should not require any mapping changes. (If you made the previously mentioned mapping changes to input_select but later decide to use a phono preamp and the input selector set to PC please be sure to revert the changes to avoid other possible issues.)
 

Posted Thu 15 Mar 18 @ 9:27 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
It is normal to get the Timecode signal/noise to the Output, if set to LINE/PHONO. What needs to be done here is ...
- Have the SOURCE selectors to PC/USB positions
- Have Timecode input lines to your VirtualDJ Audio Setup
- Have the TC enabled on the decks (from the special TC buttons that will appear on the decks of VirtualDJ GUI)

The most important part of this test, is to see if the Audio Interface of the Pioneer DDJ-SX2 is switched to 2OUT/2IN, thats the name you should see if you look at the list of the available sound cards if you click in VirtualDJ Audio Setup and if all went well, the special Pioneer DDJ-SX2 button you see at the top of that window, should offer this "new" sound card name.
By default, the Timecodes are not added to the Audio setup, so you will need to manually add them. Use the TIMECODE SIGNAL button you see at the top of the Audio tab of settings.
Your Audio setup should look like the one shown below, with the exception that instead of linein1 and linein2, you should have timecode 1 and timecode 2 lines..


It is advised to use the Pioneer ASIO for this test. Not sure if WASAPI properly offers the Inputs necessary for Timecode.

If something not working properly , and the above have been followed (so dont use the LINE/PHONO source positions), please provide a screenshot of your current Audio Setup in VirtualDJ.
 

Posted Fri 16 Mar 18 @ 12:34 am
Pre-posting Update: While trying to get additional screenshots including one containing the actual calibration failure pop-up after taking the following 5 screenshots VDJ opened and accepted the calibration made while using a preamp WITHOUT a preamp connected with the SOURCE selectors to PC/USB position. I'll add more information at the end of the post.

The following is the audio setup used:


These are the results with the SOURCE selectors to PC/USB position (Left is on, right is off):

If you look very closely there is a difference between the timecode when running and when off, but calibration would inform me there was no timecode running/fail.

These are the results with the SOURCE selectors to the PHONO position:


These are the results with the SOURCE selectors to PC/USB position AND with a preamp:


These are the results using WASAPI (Simply changing ASIO to WASAPI on the audio settings dropdown):


Additional pre-posting information:

After djdad mentioned that "It is normal to get the Timecode signal/noise to the Output, if set to LINE/PHONO." I exited VDJ with the audio settings the same as the first and fourth images (ASIO, PC/USB position, and preamp) I double checked other DJ software incorrectly thinking that the PHONO position was used and found that, in fact, the PC/USB position was used and confirmed the timecode signal was accepted even without the use of a preamp. I closed that DJ software and reopened VDJ to find that the timecode was calibrated and ready to go even without the preamp connected. To reiterate, I closed VDJ with a preamp connected, disconnected the preamp and opened separate DJ software, tested and changed timecode related options, closed the separate DJ software, and opened VDJ without the preamp connected and it accepted the calibration.

On a side note, changing timecode related settings in this separate DJ software has previously, currently resolved in my case, rendered the "DDJ-SX2 play/cue buttons and jog wheel unresponsive" even in VDJ. This issue persisted even through soft and hard resets/restarts of both hardware and software as well as changes made directly to the hardware through the use of utilities mode on the DDJ-SX2 itself. The issue was not resolved until again making timecode related settings changes in the separate DJ software.
Also, having both inputs with the same name makes choosing the correct one difficult, however it accepts chan 1 & 2 and chan 3 & 4 and uses that information to choose the correct 2OUT/2IN named input.

I may do some additional testing to find a cause for the sudden acceptance of the phono level timecode signal when it previously informed me that the timecode was not playing, however for now I am satisfied that I can remove the additional hardware (preamp) from this setup.

Edit: Additional Information and corrected typos.
 

Posted Fri 16 Mar 18 @ 2:15 am
djdadPRO InfinityDevelopment ManagerMember since 2005
OK, i think there must be a MIDI Out message that tells the Hardware what is connected to the Inputs of CH1 and CH2 (Phono or Line) to decide if it needs to amplify the signal or not. This must be an option in Serato settings i believe. Will investigate further.
Thanks for your feedback

EDIT. If you click on the "ASIO" button you get under the Outputs and Inputs lines in VirtualDJ Audio Setup, you should get the Pioneer Utilities / ASIO settings window. Any chance there is an option there to select Phono or Line Inputs for the USB Inputs 1,2 & 3,4 ?
 

Posted Fri 16 Mar 18 @ 3:35 am
When in the Pioneer Utilities / ASIO settings window I do not see an option to select Phono or Line Inputs for the USB Inputs. I see the following:


Additionally, in the separate DJ software there is a Deck Setup panel under Audio Settings that allows you to switch between Turntable, which enables phono compatable inputs, and CDJ, which sets all channels to line level inputs.

I can confirm that simply starting and exiting the separate DJ software, at least while on the Turntable setting mention above without VDJ running, allows VDJ to read the timecode signal without a preamp, and when the DDJ-SX2 is put into standby and then turned back on this ability is lost and VDJ can no longer read the timecode signal.
 

Posted Fri 16 Mar 18 @ 4:35 am
djdadPRO InfinityDevelopment ManagerMember since 2005
As of Builds 4209 the DDJ-SX2 can now offer Timecode inputs

The new mapping* files now offer a DDJSX2 DVS Pad page, which can be selected from the Pads of VDJ GUI and offer DVS ON/OFF Pads 1 and 2 to set the unit to either the "Controller" mode or the "DVS" mode. When the DVS mode is enabled, 2 additional Pads (3 and 4) are offered to select the DVS Input types.

* requires the factory default mapping to be chosen from Controllers tab


Some useful notes...
- Each time the controller mode is changed, you will need to visit the Audio setup, click on the Pioneer DDJ-SX2 special button at the top and then click on APPLY.
If you wish to have an automation, so that the Audio setup is applied automatically each time you use Pads 1 or 2 (or the unit gets connected to VirtualDJ), open VirtualDJ Settings-->OPTIONS tab and set the ControllerNotification setting to !DDJSX2, Doing this, you will be getting a detection window on each re-connection and you will need to click on the "Use Sound card" button to apply the pre-defined Audio setup for each case.

- The Controller mode offers a single Input which is used to record your mix along with the Microphone and AUX inputs.

- The DVS mode turns the sound card of the DDJ-SX2 into 2IN2OUT and the 2 Input Channels are used for Timecode (or LineIn). There is no special record input in this mode, so the REC within VirtualDJ will only record your mix and not MIC or other analog sources.

- The sound card in "Controller" mode is 24 bit, while the one in DVS mode is 16-bit

- You cant have one Input as LINE and the other as PHONO. Due to firmware limitation, both inputs need to be set to the same type.

- If you wish not to get the Detection window when modes are changed or on every unit re-connection, set the ControllerNotification setting to DDJSX2


We have tested on both Mac and Windows and was working well during our tests, but would appreciate further feedback.



Note that the mode switches require the factory default mapping to be used. In case you need this feature (to switch to DVS), and still use your Custom mapping, you can add the following lines to your/Mappers/ Custom xml file
<map value="DNC_DVS_ENABLE" action="var_equal '@$sx2_dvs' 1" />
<map value="DNC_DVS_DISABLE" action="var_equal '@$sx2_dvs' 0" />
<map value="DNC_DVS_PHONO_S1" action="var_equal '@$sx2_dvs_phono' 1" />
<map value="DNC_DVS_PHONO_S2" action="var_equal '@$sx2_dvs_phono' 1" />
<map value="DNC_DVS_PHONO2" action="var_equal '@$sx2_dvs_phono' 1" />
<map value="DNC_DVS_PHONO1" action="var_equal '@$sx2_dvs_phono' 1" />
<map value="DNC_DVS_LINE_S1" action="var_equal '@$sx2_dvs_phono' 0" />
<map value="DNC_DVS_LINE_S2" action="var_equal '@$sx2_dvs_phono' 0" />
<map value="DNC_DVS_LINE2" action="var_equal '@$sx2_dvs_phono' 0" />
<map value="DNC_DVS_LINE1" action="var_equal '@$sx2_dvs_phono' 0" />
 

 Selected as best answer Posted Wed 21 Mar 18 @ 6:41 pm
These new options seem to work on my end in VDJ 8.2 early access pc build 4189.1409, however I did have an issue where a loop was created with the controller continuing to disconnected and reconnected until I was informed that drivers failed to install. Setting the DDJ-SX2 to standby and turning it back on resolved the issue. It happened when switching between DVS ON/OFF as well as Line/Phono options quickly both on the GUI and the DDJ-SX2 pads after closing separate DJ software and opening VDJ. I could not replicate the issue.
 

Posted Fri 23 Mar 18 @ 11:00 pm
Can't edit the last post, but ran into another issue;
When I launched VDJ in DVS mode, previously exiting while in DVS mode, the timecode was very erratic, looking similar to the WASAPI signal but wider and with even more noise. Calibration failed and changing from line to phono and back did not help resolve the issue. I had to toggle DVS off and back on to get a clear signal. I have not been able to replicate the issue.
 

Posted Mon 26 Mar 18 @ 6:17 am
NoClicksOnMe wrote :
It happened when switching between DVS ON/OFF as well as Line/Phono options quickly both on the GUI and the DDJ-SX2 pads after closing separate DJ software and opening VDJ.


Due to the nature of DVS mode on SX2 please avoid doing these things "quickly"

Reason:
When you enable DVS mode the unit DISCONNECTS from host (PC/MAC) and RECONNECTS as a new device. Same thing happens when you disable DVS mode.
"Quick" mode changes mean that the unit will try to disconnect/reconnect too many times on a very short time interval and this can lead your OS (especially Windows OS) to think that the device is malfunctioning and therefore stop trying to connect.
If the OS thinks that the device is malfunctioning any further operations will be ignored by the OS until the unit is either physically disconnected from the USB interface, or rebooted.
 

Posted Mon 26 Mar 18 @ 9:13 am
I initially did not expect the DDJ-SX2 to disconnect because when changes are made in separate DJ software the unit is not restarted. Before the unit was disconnected when changing DVS mode using the interface I noticed the pads were lit and tested each of them to verify the pads were able to make changes successfully, which they are, then used the GUI to switch to DVS Mode with Vinyl option as desired.

On a side note, having DVS mode changes on a non-hardware selectable pad mode can cause pad mode leds to be incorrectly lit and possibly lead to switching modes instead of going to cue points/etc. causing the timecode signal to be lost or audio cutout due to the disconnection.
 

Posted Mon 26 Mar 18 @ 6:02 pm
so i have a pioneer DDJ SX2... im trying to use tracktor Mk2 timecode vinyl..... ive set it up in VDJ... calibrated it and the vinyl now controls the cued up track.... but instead of hearing the track i can only hear the timecode!!! any ideas ?????
 

Posted Sun 21 Feb 21 @ 1:17 am
Manny moonshine wrote :
so i have a pioneer DDJ SX2... im trying to use tracktor Mk2 timecode vinyl..... ive set it up in VDJ... calibrated it and the vinyl now controls the cued up track.... but instead of hearing the track i can only hear the timecode!!! any ideas ?????


Look in settings, search for SX2 ..
If you are using modern VirtualDJ some of the controller options may have moved from pads to Settings=>Options instead.

But same logic as described above in thread should apply.. Enable DVS and set to phono

 

Posted Sun 21 Feb 21 @ 4:03 pm
I've read this entire Timecode inputs section and followed all the examples, but whatever I do I'm not able to get the 2IN/2OUT on my pioneer DDJ-SX2.
Pioneer is al the latest firmware and drivers too.
Am I missing something?
 

Posted Sun 02 May 21 @ 3:33 pm
Never mind, problem fixed
 

Posted 5 days ago @ 6:41 pm