Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: Rane 72 mk1
NosvenLE userMember since 2015
The "back" button on the Rane 72 that allow you to jump from browser list to browser tree works less than 1% of the time. I know the back button on the touch screen can do this, but the hardware button is better. This is with VDJ build 6067 demo version and the previous build versions.

You can rule out hardware button being faulty, because no matter how many times I press this button while in the setting/controller page of VDJ I can see the action: "back" and "browser_folder" react to the button pressed.

Posted Sun 01 Nov 20 @ 5:26 pm
When I press the Back button it just iterates browser, then folder, then sideview, then once you're in sideview you're stuck - Back does nothing - long click or quick click. I compared the VDJScript with my Denon MC6000Mk2, whose back button works perfectly, cycling indefinitely through the different browser panes, and the VDJScript seems identical.

I can't open sub-crates either (I haven't yet got round to copying my Serato crates into Virtual Folders) - I can open into the top layer, but to enter a crate inside a crate I have to use the mouse.

Posted Mon 02 Nov 20 @ 10:35 am
The issue with BACK button has been fixed for next update.

Now, for browsing folders:
In order to open a folder (that contains subfolders) press the browse knob.
In order to close a folder (that contains subfolders) hold down the browse knob
In order to open a folder that contains BOTH subfolders and tracks hold down the browse knob

Posted Mon 02 Nov 20 @ 7:09 pm
Fantastic, thanks!

Posted Tue 03 Nov 20 @ 9:44 am
NosvenLE userMember since 2015
Thanks you.

Posted Wed 04 Nov 20 @ 12:44 am
NosvenLE userMember since 2015
I've also notice the "EFFECTS" button located directly under the "LP/HP" filter knob on the 72 is mapped to VDJ FX_ON. This button is for sending the sampler sounds to the hardware effects, by enabling bank 1 or bank 2 sampler via touch screen. If I press the "effects" button while the sample banks 1 or 2 is engaged, the FX_ON for the respective deck is triggered. In short the "EFFECTS" button should not be triggering the FX-ON.

Also the bank A "FLEX FX" button don't light up when engaged with VDJ. You have to press the button two times before it light up.

Posted Mon 16 Nov 20 @ 3:11 am
Please read carefully:
https://www.virtualdj.com/manuals/hardware/rane/72/layout/effects.html

There are certain firmware limitations when using effects with Rane 72.
72 was designed for Serato where their approach to effects is completely different than VirtualDJ's (e.g. 6 global effects on 2 banks vs unlimited "per deck & master" effects)

PS: The button you mention (item 43) is defined as "SAMPLER_FX" but it's not mapped to do anything. That's because it works on hardware/firmware level.
As the description says, it passes the sound of the sampler channels to the FLEX FX engine.
So, make sure that you didn't accidentally mapped it to something.
https://www.virtualdj.com/manuals/hardware/rane/72/layout/iocontrols.html

Posted Mon 16 Nov 20 @ 9:32 am

Posted Mon 16 Nov 20 @ 4:17 pm
It has been fixed already on latest EA

Posted Mon 16 Nov 20 @ 4:24 pm
NosvenLE userMember since 2015
PhantomDeejay wrote :
Please read carefully:
https://www.virtualdj.com/manuals/hardware/rane/72/layout/effects.html

There are certain firmware limitations when using effects with Rane 72.
72 was designed for Serato where their approach to effects is completely different than VirtualDJ's (e.g. 6 global effects on 2 banks vs unlimited "per deck & master" effects)

PS: The button you mention (item 43) is defined as "SAMPLER_FX" but it's not mapped to do anything. That's because it works on hardware/firmware level.
As the description says, it passes the sound of the sampler channels to the FLEX FX engine.
So, make sure that you didn't accidentally mapped it to something.
https://www.virtualdj.com/manuals/hardware/rane/72/layout/iocontrols.html


I didn't accidentally map button 43 to anything. The 72 is on default mapping. Here are the settings that cause VDJ effect to turn on. 1st turn on bank A and bank B "FX1" on Rane 72. 2nd assign the sampler (via touchscreen) to hardware sampler effects on Rane 72. 3rd press button (item 43) on Rane 72 and you will see VDJ effect turn on. This is still build 6067.

Posted Tue 17 Nov 20 @ 3:12 am
PhantomDeejay wrote :
It has been fixed already on latest EA


Exciting, thank you! (Apologies for side-tracking the thread. I haven't been able to repeat this issue, but I am on the last but one 72 firmware and that button has never worked in Serato, VDJ or standalone.)

Posted Tue 17 Nov 20 @ 10:58 am
Nosven wrote :
I didn't accidentally map button 43 to anything. The 72 is on default mapping. Here are the settings that cause VDJ effect to turn on. 1st turn on bank A and bank B "FX1" on Rane 72. 2nd assign the sampler (via touchscreen) to hardware sampler effects on Rane 72. 3rd press button (item 43) on Rane 72 and you will see VDJ effect turn on. This is still build 6067.

When you assign the sampler via touchscreen on right or left side in theory you would assign it on one of the two effect units.
However, that's for Serato. VirtualDJ doesn't have effect units. It has effects "per deck, master, mic, sampler"
Given the fact that the firmware of the device assumes you're using Serato, a lot of things are done on hardware/firmware level with a specific logic.
The button (41) works correctly if you assing it somewhere, as long as you "disarm" the software (brown) effects before you use it.
That's a firmware limitation we cannot bypass because the unit is designed to work with a specific logic.
While the button (41) sends only one MIDI note, depending on the touch screen assignment the firmware sends other notes as well to ensure "proper" operation with Serato effects. However this makes things more complex for any software other than Serato. And we cannot simply "ignore" or "remap" those other notes to work differently because the unit doesn't let us know if you assigned sampler on a side, or even on which deck you assigned which unit.
That's why there's a chapter on the manual that says how to setup the FX assignment on screen in order to get the best results with VirtualDJ



Posted Tue 17 Nov 20 @ 3:19 pm
NosvenLE userMember since 2015
Thanks for explaining Rane firmware limitations. I thought it was a mapping issue on VDJ part, so I unmapped buttom 43 only to find that the effects paddles were no longer assigned to trigger deck effects. What a shame. I wonder if Serato dictates to Rane, "It's all my way or the highway."

Posted Sat 21 Nov 20 @ 5:55 pm
TBH it's not about dictating. It's about using a wrong logic.
E.g:
Instead of mixer just sending MIDI messages for each button on software and let software treat them and do it's job, do certain things on firmware level and then pass that data on software.
This logic offloads software from doing some operations, but there's no real gain in processing power e.t.c. On the other side it brakes certain operations with any other MIDI capable software.

On mappers tab you can see that depending on effects state you get several MIDI messages when you pull the levers for instance. It's the result of the firmware process mentioned above. A better logic would be to send just one message (Lever is pulled) and let software handle it...

Posted Sat 21 Nov 20 @ 6:53 pm
I observed a waveform shift between the two tracks when I use the extreme pitch with the 50% setting activated. This shift is not on the computer screen and the two tracks are still beatmached. for that reason long transition on that condition with the Rane 72 screen is not usable
Note The same manipulation on SERATO does not do it so maybe it's not really an hardware issue or computer.
if needed i got a short video to show the issue i mentionned
thanks for your help

Posted 6 days ago @ 10:37 am