Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: macOS Catalina problem
I recently updated to Catalina 10.15.5 and immediately I have big issues. I tried everything to connect my DJM-2000 to my Macbook Pro. DJM-2000 driver settings 6-channel output 2-channel input 16 bit. Virtual DJ PRO reads new device as DJM-2000 and Pioneer sound card appears in the hardware. Once you choose and click APPLY, Output stays as Built-in Output (not changing to DJM-2000 automatically) and there is no sound from mixer. I can only play off the Mac speakers.
I notice that MacBook Pro in Audio Devices: DJM-2000 Output showing 8 channels.
Any idea how to solve this problem?

Thank you

Posted Tue 30 Jun 20 @ 10:41 pm
Did you look at Pioneer's Catalina compatibility chart? The one that lists the DJM-2000NXS but not the DJM-2000?

Posted Wed 01 Jul 20 @ 8:02 am
AdionPRO InfinityCTOMember since 2006
When you check the drop-down arrow next to 'Built-in output' you also don't see the DJM?

Posted Wed 01 Jul 20 @ 8:50 am
Hi There,

I have also a DJM 2000 and tried getting it to work under Mac Mojave & Capitan but there was No Sound Output, but what I did discover was that by Default the Mixer is set to 48HZ. Try Switching over to 44HZ as that suddenly made everything start working.
But now I am not sure if I have a Fault on the 48HZ side or Apple has stopped supporting the better quality sampling.
But Give that a go, 44HZ.

Posted Wed 01 Jul 20 @ 9:23 pm
Thank you for comments.
I can change manually to DJM, but settings automatically goes to COMPUTER AUDIO.

And, I try both 44Hz and 48Hz, but still have the same problem.
Thank You.

Posted 7 days ago @ 4:20 am
AdionPRO InfinityCTOMember since 2006
So looks like it's working ok then when you manually select DJM?

Posted 7 days ago @ 6:06 am
djdadPRO InfinityDevelopment ManagerMember since 2005
Can you please follow these steps and provide the asked data..
1. Open VirtualDJ, goto Settings->OPTIONS tab, then search for CreateMidilog setting.
2. Set to Yes.
4. Close VirtualDJ
3. Goto Documents/VirtualDJ folder and delete the file Log Report.txt
4. Make sure DJM is powered on and connected to USB
5. Open VirtualDJ, wait for the Detection window or 2-3 seconds in case you have set not to show.
6. Close VirtualDJ
7. Post here the content of the re-generated Log Report.txt file you will find in Documents/VirtualDJ folder

Can you also post a screenshot of the Audio Midi Setup (it's in Mac Applications->Utilities)


Posted 7 days ago @ 10:11 am
Hi Again,

I did actually forget to say, you need to change the Sample rate from 48HZ (Default) to 44HZ which is under the Audio Devices in the Audio Midi Setup & not in the VDJ app.

My DJM 2000 would not Work at 48HZ, but is Working Fine at 44HZ.

Hope that Helps

Posted 7 days ago @ 10:14 pm
It's 44.1kHz and 48kHz (Kilohertz), not 44HZ and 48HZ (Hertz)...

Posted 6 days ago @ 8:32 am