Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: MCX8000 Bug
vjmundyPRO InfinityMember since 2014
Hi team, I recently bought a MCX8000, Machine works fine, but the thing is, when I plug machine by USB, and open virtual DJ (normal connection), software works so bad, song are in slow motion, If i unplug and plug by usb machine keeps same behavior, I have to power off and turn on, in this way problems is solved, curiosly thing is when y power off and ON, at this moment virtualdj send me the notificacion of device has been plugged in.

How can I do, to avoid turn off and power on, that could damage usb ports.

Posted Mon 11 Mar 19 @ 3:56 pm
What sound card drivers are you using?

Posted Mon 11 Mar 19 @ 4:01 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Are you using USB 2.0 or 3.0 port to connect the MCX8000 ?
If you go to Settings->Audio Setup and click on the APPLY button, do you still get the same audio issue ?

Also try this...
with the MCX8000 connected to USB and before starting VDJ, goto Windows Sounds and make sure the MXC8000 is not the default playback device for Windows , so choose your Builtin sound card instead. Then open VirtualDJ and see if you get the same issue

Posted Mon 11 Mar 19 @ 4:10 pm
vjmundyPRO InfinityMember since 2014
Curiosly is a Mac with 10.9, Mavericks. SO, works very good, and the last version of virtual DJ too.

If you go to Settings->Audio Setup and click on the APPLY button, do you still get the same audio issue ?
the first thing that i have tried is this, Bofere I had a Pioneer SX,. In Virtual DJ configs appear that a Denon MCX8000 is activated to use.

Posted Mon 11 Mar 19 @ 5:36 pm
vjmundyPRO InfinityMember since 2014
Can I do some test about this to fix this issue?

Posted Wed 13 Mar 19 @ 1:32 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
Here is one test you can do, to see where the bad performance comes from.
With the MCX8000 connected, open VirtualDJ and goto Settings-->CONTROLLERS tab.
On the left-top list, you will see Keyboard, MCX8000 and 2 more for the Displays.
Select one of the Displays from the list and then from the Right side, select the "Ignore" option from Mappings.
Do this for the other Display too.
Close VirtualDJ and restart.
You wont have the screens working, but see if without them, you still get the same issue.


BTW, you can still select your builtin soundcard as default on Macs - instead of the MCX8000 - if you goto Utilities ->Audio Midi Setup

Posted Wed 13 Mar 19 @ 2:05 pm