Quick Sign In:  

Forum: General Discussion

About VirtualDJ & DJing in general
If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: EQ auto switches to disabled on track load.
First and foremost I'm a hobby bedroom DJ, I'm doing it for fun, don't want to make money on it or anything like that. I just like playing around. I've been trying to learn VDJ and I really like the instant steam thing. It's really cool... when it allows me to use it.

What is happening is even though I pick the "EZRemix" option for the EQ (both on load and the drop down triangle on default pro skin 2-deck), as soon as I load a track it's switching to disabled/normal EQ. If I unload a said track it switches back.

Here is a video of it happening: https://imgur.com/a/JOkzscI

Let's get some things out of the way:
-Fresh install of VDJ
-Use DDJ-SB3
-Windows 10 Pro fully updated (version 20H2)
-Ryzen 3900X
-Nvidia 3090 FE (Driver version 460.89)
-64GB Ram
-Over 20TB total storage between HDD and SSD/NVMe.

I'm not sure what is making it do this, but it is happening if my controller is plugged in or not. I saw some things where people were having trouble with something on the fringe of this and when I try to change the math engine from GPU VDJ crashes.

I have some other issues but I'll wait until I get this sorted out. Kind of a feature I want to play with. It's been doing this since the entire time since I've been subbed for the last few months.

Any other info or examples of something or what ever, more than happy to provide.
 

Posted Tue 05 Jan 21 @ 8:53 am
AdionPRO InfinityCTOMember since 2006
Make sure mathEngine is not disabled, and usePrecomputedStems is set to Create manually.
 

Posted Tue 05 Jan 21 @ 9:29 am
Adion wrote :
Make sure mathEngine is not disabled, and usePrecomputedStems is set to Create manually.


They are set that way ~thinking face~

https://gyazo.com/c928fe01cf4189eae9a4a433c879139d

I also notice when I do precompute on a track, it flashes for a second but I don't think it did anything. I check the folder with the track and no vdj stem file.
 

Posted Tue 05 Jan 21 @ 9:39 am
AdionPRO InfinityCTOMember since 2006
Try to put maxStemLength to default by using the X, and set mathEngine to Automatic.
 

Posted Tue 05 Jan 21 @ 9:41 am
Adion wrote :
Try to put maxStemLength to default by using the X, and set mathEngine to Automatic.


No dice. Same problem.

EDIT: Reset all settings to default but same result.

EDIT 2: Okay so deleted EVERYTHING. Uninstalled. Cleared the folders and got fresh copy from the website. Now it did work on the first opening. When I close it out and then reopen it right back to square one. Def not going to be uninstalling and reinstalling every time I want to open the software.
 

Posted Tue 05 Jan 21 @ 9:50 am
Adion wrote :
Try to put maxStemLength to default by using the X, and set mathEngine to Automatic.


Okay so update here, and it's an odd one.

So tried a few more things, nothing seemed to help. I was wondering if SMV (AMD's VM feature) was doing something but that didn't turn out to be the case.

I got really frustrated and just left VDJ open, and when I tabbed back over to it around 17 mins after it was opened, stems started to work.

Did it again and when I loaded up same behavior, not working. But left it going with a timer and 15 ish mins in then was working.

Third time, to establish a pattern took 18 mins and 40 some odd seconds to start using stems, except this time I took some video:

https://www.youtube.com/watch?v=0kxa1NIiMOo&feature=youtu.be

Showed this to a friend as well and we are coming up blank other than something is processing in the background of VDJ or times out or something. Mind you CPU usage is very low here and it's on a 3900x with a RTX 3090 so no idea. Was watching taskmanager and system processes in powershell and nothing pop'ed out at me.
 

Posted Thu 07 Jan 21 @ 5:20 am
 

Posted Thu 07 Jan 21 @ 7:33 am
 

Posted Thu 07 Jan 21 @ 9:25 am
 

Posted Tue 12 Jan 21 @ 6:35 pm
LIMOLPRO InfinityMember since 2003
normal, any video card that is not powerful may not operate the rods.
it is always advisable to go through the processor which is more powerful to operate the rods
 

Posted Tue 12 Jan 21 @ 7:20 pm
DJNemobob wrote :
Hey,

I managed to get stems working again with a workaround using the CPU instead of the GPU. See the latest post on my thread: https://www.virtualdj.com/forums/239114/VirtualDJ_Technical_Support/Stems_not_working_crash_when_changing_math_engine_settings.html

It does the same thing for me either on CPU or GPU. Also unless I wait the 15-18mins for it to 'time out'/error out/or whatever, attempting to change the engine in software is making it hang up and have to force close. Not to mention the phantom process is there if don't wait.

The latest post you did with the video is the same thing I've been talking about. Support is of no help and now been 6 days since they have said anything. I need to contact some people high up at Atomix. Support apparently is not actual support.

They asked me if my computer was a laptop after I've multiple times told them I have a 3090 FFS.
 

Posted Thu 14 Jan 21 @ 10:08 pm
LIMOL wrote :
normal, any video card that is not powerful may not operate the rods.
it is always advisable to go through the processor which is more powerful to operate the rods


Thanks for not reading. I have a RTX 3090, if this is NOT powerful enough then all other video cards in the market wouldn't work as well.
 

Posted Thu 14 Jan 21 @ 10:09 pm