Forum: General Discussion

About VirtualDJ and DJing in general

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: Glitchy VDJ
Hello
I’m wondering why my VDJ sometimes gets annoyingly glitchy when trying to play.
I’m thinking that perhaps it’s my Mac, which I keep on and put into sleep when not using. Should I be doing a complete shutdown to get rid of the glitchy VDJ problem or is there something else that I should be looking at?

Posted Sat 18 Apr 20 @ 4:08 am
Give us some more info to go on:

Which version of VDJ (inc build no)?

Which Mac? Spec?

What's glitching? The GUI? Audio? Video?

What controller are you using? Does VDJ glitch with/without the controller?


Posted Sat 18 Apr 20 @ 7:40 am
Cronker1ControlleristMember since 2019
Hi
Running VDJ8
iMac 2008 with 3.06 ghz intel core 2 duo
Pioneer DDJ-SB3
Has been happening since before the controller.
Some days are better than others.
Have reinstalled VDJ8 a couple of times

Posted Mon 20 Apr 20 @ 7:46 am
Please answer these questions. Which version of VDJ (inc build no)? You didn't include the build number.

What's glitching? The GUI? Audio? Video? Can you explain what the software is actually doing that you don't like?

Posted Mon 20 Apr 20 @ 4:23 pm
Cronker1ControlleristMember since 2019
I’m not sure how to find the “build” (?) but it’s 8.4 if that’s what you are asking. The issue is microsecond stops during play on the audio and play screen - quite often. If I record, the glitch isn’t there.
I don’t use video and I’m sorry but I don’t know what GUI means.
I’m not an IT expert, just asking if anyone has a suggestion to what might be causing this.
Thanks

Posted Thu 23 Apr 20 @ 9:04 am
The build number is located at the bottom of his picture.

Gui stands for the graphical user interface. In other words your screen.

Posted Thu 23 Apr 20 @ 7:34 pm
Cronker1ControlleristMember since 2019
Thanks for that.
So the build is v8.4 b5647
The microsecond stopping effects both the audio and the GUI

Posted Fri 24 Apr 20 @ 8:59 am
Cronker1ControlleristMember since 2019
Can anybody help with this? It’s still a problem and I think I have given the information asked for, but it’s clearly been ignored
Maybe just move to Serato?

Posted 6 days ago @ 2:54 am
Have you tried adjusting latency?

Posted 5 days ago @ 7:20 am
It sounds like the issue is with your machine rather than software.

Posted 5 days ago @ 7:51 am
Simple test - can you play a music file just in the Mac OS, without it glitching?

Glitching only when playing, but not when recording seems a bit backwards, as playing should be less stressful than recording.

Posted 5 days ago @ 8:06 am
Cronker1ControlleristMember since 2019
It doesn’t happen when I play out of iTunes

Posted 5 days ago @ 4:45 pm