Forum: Wishes and new features

Features you would like to see in VirtualDJ
Topic: Automatic key match
Good day,

Every time I start up VirtualDJ 2020 (I think this is the version that I own on my computer), it automatically turns the "automatic key match" back on after I previously turned it off.

I always turn it off because to be honest, I find this option kind of annoying, especially whenever I practise, because imagine having to restart the whole song in the middle of a party the whole time because it has the wrong pitch because of this reason!

Now my question is: how do I prevent the "automatic key match" option from secretly turning itself back on whenever I restart VirtualDJ?

Thanks in advance!
-Marcia :)

Posted Fri 04 Oct 19 @ 3:57 pm
Try turning off autoKey.

Posted Fri 04 Oct 19 @ 4:21 pm
groovindj wrote :
Try turning off autoKey.


Thanks :) I looked all over the settings and couldn't find any logical options beforehand, even searching over Google didn't help. Guess I'm the first ever who came with this question!

Posted Fri 04 Oct 19 @ 4:39 pm
marciaandthedjmachine wrote :
couldn't find any logical options


Hmmm..... You had an issue with the key, but didn't search VDJ config for the word 'key'?

It's also covered in the manual deck options #6.




Posted Fri 04 Oct 19 @ 4:45 pm
I must admit, I had the same trouble. Even though I would turn auto key match off, the next time I loaded up the software, it would default to auto key match.

I searched in the settings with the key word 'key', and set both the 'autoKey' and 'resetKeyOnLoad' options both to 'No' and have found this works. I've sent a screen grab to show the settings

Posted Thu 30 Jan 20 @ 8:41 pm