Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: Creating definition to midiplus SmartPAD LED issue
Hello, i'm trying to configure a Smartpad with virtual Dj creating his definition, i'm okay until i have to mess with the leds , for example:
in miditrace if i wanna to turn on a red led on the button 1 i only need to write "90 00 7F 00, turning it off it's 80 00 7f(any value) 00

My problem is in virtual, with " <led note="0x00" value="0x7f" zero="" default="sampler_pad 1" name="LEDR_SAMPLER_1" />" it's turn on alright, but dosn't turn off (when using blink, or whatever command i just use <map value="LEDR_SAMPLER_2" action="sampler_pad 2 ? on : nothing (or off, etc)" />)


How i can do to fix this? i'm trying diferents metods and right now i'm using : <sysex value="80000000" zero="" name="LEDOFF_SAMPLER_1" /> and a mapping to help me with , but i don't feel right.

Greetings from Argentina!

Kevin.

Posted Sat 28 Sep 19 @ 2:27 am

<button note="0x00" name="R_SAMPLER_1" deck="1" channel="0" />

<led note="0x00" default="R_SAMPLER_1" name="LED_R_SAMPLER_1" deck="1" channel="0" />

Posted Sat 28 Sep 19 @ 4:17 pm
PhantomDeejay wrote :

<button note="0x00" name="R_SAMPLER_1" deck="1" channel="0" />

<led note="0x00" default="R_SAMPLER_1" name="LED_R_SAMPLER_1" deck="1" channel="0" />


thanks for reply PhantomDeejay

I tried this but it's the same, the led stays on , even with a off command on vdj

Thanks anyway! and have a good evening

Posted Sat 28 Sep 19 @ 7:44 pm
Do you have a file with the MIDI specs of the device?

Posted Sat 28 Sep 19 @ 8:28 pm
Hi, any update on this one?
I just bought the MidiPlus Smartpad.
Would be nice to be able to control the LEDs.

Posted 5 days ago @ 9:15 am