Forum: General Discussion

About VirtualDJ and DJing in general

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: Pitch lock and new version of virtual Dj
Hello. I use simple script for "sync" button of my ddj rr: sync & pitch_lock.
So if i press "sync" once, pitch lock is "on" (i need pitch lock "on" in 99% of cases when i use "sync"). If i press "sync" again - pitch lock is "off".
But in new version of Virtual Dj something has changed. There has been added new options "auto pitch lock". And my script does't work anymore. Then i swapped commands in my script ("pitch_lock & sync" instead of "sync & pitch_lock") and it works again, but not completely. When i press it first time - pitch lock is "on", but when i press it again - nothing happens. So, to turn pitch lock off i need double click my "sync' button. Not big problem of course, but maybe there is option to do it the old way?
And i don't understand the logic of this process, why in new version of software "pitch_lock & sync" works, but "sync & pitch_lock"- not? Its the same commands. And why double clicking turning pitch lock "off", but one click - not?

Posted Sat 07 Sep 19 @ 7:55 am
With the new option (autoPitchLock) enabled, pitchlock will turn ON automatically when 2 tracks are in sync.

Therefore with autopitchlock option enabled:
sync = sync + pitchlock on
So effectively:
sync + pitchlock = sync + pitchlock on + pitchlock. Since pitchlock is a toggle the second call will actually turn pitchlock off
pitchlock + sync = pitchlock (toggles to on) + sync + pitchlock on. This will always turn pitchlock on because the last action has explicitly a "on" switch.

Now your problem can be solved with two ways:
1) Use your old scripts and turn off "autopitchlock" setting
2) Modify your SYNC button to: pitch_lock ? pitch_lock off : sync

Posted Tue 10 Sep 19 @ 8:46 am
..."1) Use your old scripts and turn off "autopitchlock" setting"... - it's not working the old way, as i mentioned before, even with new option "off"
but your new script should help, thank you a lot! I'll check later

Posted Sat 21 Sep 19 @ 5:53 pm