Forum: General Discussion

About VirtualDJ and DJing in general

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: SHORTCUT KEYS STOP WORKING WHEN CURSOR IS CLICKED IN BROWSER AREA
WHY DOES SOME SHORTCUT KEYS STOP WORKING WHEN CUSUR IS CLICKED IN BROWSER AREA? HELP ADVICE PLEASE ON HOW TO KEEP THIS ACTION FROM STOP FREEZING.

Posted Wed 30 Jan 19 @ 10:04 am
That is the expected behavior and is pretty consistent on most Dj'ing software where keyboard mapping is available. Why would you want it to continue to work?

Imagine if "a" was mapped as say play/pause and then you wanted to search for a song that contained the letter "a", well you can see what would happen if the shortcuts did not get disabled.

Posted Wed 30 Jan 19 @ 10:10 am
As Mr DJ Mel writes the shortcuts needs to be disabled when you use the keys for searching

Posted Wed 30 Jan 19 @ 10:27 am
PhilWPRO InfinityMember since 2011
Just press escape. I believe that gets you back to normal keyboard functionality.

Posted Wed 30 Jan 19 @ 2:54 pm
AdionPRO InfinityCTOMember since 2006
It's also an option that you can turn off, named browserSearchByFirstLetter

Posted Wed 30 Jan 19 @ 3:32 pm
SORRY FOR LATE REPLY, WAS UNAVAILABLE, THANK YOU ALL FOR UR ASSISTANCE. MEL AND KLAUSMOGENSEN I DONT RECALL HAVING THIS PROB WITH VDJ7 THO

Posted 6 days ago @ 1:32 am
PHILW WHEN ESCAPE IS PRESSED IT LOOPS THE SONG

Posted 6 days ago @ 1:38 am
K PHRESSH wrote :
SORRY FOR LATE REPLY, WAS UNAVAILABLE, THANK YOU ALL FOR UR ASSISTANCE. MEL AND KLAUSMOGENSEN I DONT RECALL HAVING THIS PROB WITH VDJ7 THO


Should be the same. How else would you do a search if you can't use the letters?

Posted 5 days ago @ 7:13 am
PhilWPRO InfinityMember since 2011
I thought the issue was the keyboard not working when you clicked in the search area so I suggested a solution. The escape key does remove focus from typing in the search bar. A second press, with the default keyboard mapping, activates the loop.

You could remap the escape key to do nothing in the keyboard mapping which would allow it to exit from typing mode and do nothing if you press it accidentally.

Posted 4 days ago @ 3:17 pm