Forum: General Discussion

Discussions about VirtualDJ, and about DJing in general

If you need extended support, contact our Support Team.
(*) The moderators hold the rights to move or modify posts in order to keep the discussions clear or to facilitate the search.
Topic: Milkdrop - Page: 1
bigron1PRO InfinityMember since 2010
Milkdrop freezes my screen for the first few seconds when it starts, this includes the waves, and video. This has also happened to Beatbreaker who has a very fast machine. So.. I deleted all the larger files in the Milkdrop folder in My Documents. Milkdrop now seems to work better than ever and starts instantly.

Some of the addons might slow our machines down quite a lot.

Discuss.

Posted Tue 05 Sep 17 @ 10:53 pm
laptop - initial start up takes a second or two but music and video still play
desktop - minimal pause but music and video still play

'larger files' the largest milkdrop preset file i have is 31kb and the largest texture file aside from the thumbnails is 122kb

not enough of a drawdown to be worrisome.

tho now i have questions regarding textures and how to or why i might want to add more.

Posted Wed 06 Sep 17 @ 1:18 am
bigron1PRO InfinityMember since 2010
The freeze is independent of start up loads since if I wait a period of time I still get the milkdrop start up freeze.
I deleted all the files above 20kb including those that are textures.
I take your point about the files not being that large ?
We could do with others passing comments.
It might just be my laptop..we may soon find out.
Beatbreaker passed the sensible comment that all he needs to do is start milkdrop at the beginning of the disco and thereafter all is well. That is the same as my situation. Hence it is perfectly manageable but I'm still inquisitive.

Posted Wed 06 Sep 17 @ 1:29 am
When I had my older hard drive, it could take up to 10 seconds for MD to load and while it was loading video is frozen. If MD was selected previously, when starting up VDJ again VDJ would sometimes complain about a plugin taking too long. This is just the load time without it being activated. Now with SSD drive it still freezes video etc. for about a second. The thing is it should not be doing any of this. Also when activated it can drop the frame rate quite a bit.

Posted Wed 06 Sep 17 @ 1:36 am
bigron1PRO InfinityMember since 2010
After deleting the larger files I get an instant startup and excellent performance. It might be just one file..I would not know because I deleted all above 20kb.
I'd take a guess and bet on it being one problematic file. Surely these files are too small to create load problems. One might be corrupt.

Posted Wed 06 Sep 17 @ 1:44 am
Ron? how old is the milkdrop you have installed? there was an issue with the original that had some files that were... well.. wonky is guess is the word? werent showing on screen except for black with no image

Posted Wed 06 Sep 17 @ 2:07 am
Don Moir wrote :
When I had my older hard drive, it could take up to 10 seconds for MD to load and while it was loading video is frozen. If MD was selected previously, when starting up VDJ again VDJ would sometimes complain about a plugin taking too long. This is just the load time without it being activated. Now with SSD drive it still freezes video etc. for about a second. The thing is it should not be doing any of this. Also when activated it can drop the frame rate quite a bit.


This is exactly the same thing I experienced!!

Now I will take some blame here as I usually have a lot of other things running (multiple cameras, animated logos, slideshow via TM, a couple of instances of TM running, etc, etc) but yeah I always thought it shouldn't freeze everything up as well.

I just kinda stay away from it anymore and I'll never use it when recording.

It's good for what it does but that freeze I don't like.

@Wild, I never knew that so I'll have to redownload and try it out again, Thanks for that info.

Posted Wed 06 Sep 17 @ 2:32 am
bigron1PRO InfinityMember since 2010
I'm not sure how old my milkdrop was but some of the pre-set filenames were scruffy compared to the new version I've just downloaded. Maybe that was the problem.


Posted Wed 06 Sep 17 @ 4:38 am
I deleted all 1955 milk files and it was faster and then gradually replaced them and watched it get slower. Then I deleted all of it and reinstalled with version that is up there and back to having 1955 milk files and still freezes the video for a split second. It is not about how many files etc. It should be doing nothing with those files until it needs them but it appears it is doing some processing for all of them regardless just when you select it and holding things up. If for whatever reason it needs to process all those files at load time (which is unlikely) then it could just do that in another thread and return to VDJ with no hold up. The draw time needs fixing as well. I hate to say anything but if I don't say these kind of things for some cases then no one else does and you end up with goofy answers or wondering.

Posted Wed 06 Sep 17 @ 7:33 am
bigron1PRO InfinityMember since 2010
Don why are there so many files? I would have thought a couple of hundred would be enough.

I took most of the files out and left around 400. It works fine. The files I kept were those which had good file names on the basis that if the creator took the trouble to name the files well then they might be high quality.

Posted Wed 06 Sep 17 @ 9:27 am

Posted Wed 06 Sep 17 @ 10:36 am
bigron1PRO InfinityMember since 2010
I cannot get it to freeze with my reduced number of preset files, and that's on a very slow test laptop. Also the texture files don't seem to do anything..perhaps there are many questions to ask.

We can pick the patterns we like the best..which might be a good reason for thousands of files.

It should be noted that this is a very good addon and any comments I've made do not change that status.

Posted Wed 06 Sep 17 @ 5:40 pm
dj5826PRO InfinityMember since 2008
Should be an easy enough one for any experienced script guys.

I want to set the 'cut now' button as a keyboard shortcut. Please let me know the script in order to do so.

Thanks

Posted 5 days ago @ 9:06 pm
are you asking about a 'cut now' for milkdrop?

Posted 5 days ago @ 10:04 pm
dj5826PRO InfinityMember since 2008
My apologies, yes. I thought that was assumed given the topic of the thread.

Posted 5 days ago @ 12:54 am
That's very funny. Not everyone sticks to the topic, so thank you for being thoughtful.

Posted 5 days ago @ 1:21 am
going to try to use key learn to see if I can make it happen... should be able to

Posted 5 days ago @ 1:35 am
dj5826PRO InfinityMember since 2008
I somewhat got it working. I used the command:

deck master effect_button 'milkdrop8' 2

Since I activate milk drop as a master effect and the cut now is effect button 2.

While it works and selects the cut now button, it selects all effect button 2 for any master effects. Even though I am specifying Milk drop, it doesnt restrict the command to that effect.

Any suggestions?

Posted 4 days ago @ 2:40 am

Posted 4 days ago @ 3:46 am
bigron1PRO InfinityMember since 2010
There is something a little odd going on and possibly with the hardware.

I've got two very slow 2.4ghz core2duo's both with win 10, and 5gb of memory. My main laptop is a i5 2.7ghz with win 10 and 8gb of memory. OK so I have a program called Kid3 for editing the tags of video and audio files. Now I often use drag and drop on a desktop icon to load files into Kid3. The slow core2duo's don't hang in the least but the much faster i5 hangs for a second or two. Believe it or not the old laptops are quite responsive.

Anyway I just find this hesitation odd, milkdrop seems to have a similar problem to the above hang.
The thing is that were not dealing with very large files which need time to load so what is going on?


Posted 3 days ago @ 4:22 pm
Page : [>] [>>]
95%