Forum: VirtualDJ Technical Support

For reporting any bug, questions or comment related to the latest version of VirtualDJ
(NOTE: VirtualDJ continuously updated, so many older topic on this forum are most probably already fixed in the current build)

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: having issue with ddj-rzx - there is no outbond sound
djt88PRO InfinityMember since 2017
Hi everyone , I am running windows , and I do have a strong i7 9th generation with enough memory /I do have a latest driver and firware , at first I thought there is firmware issue so i did reinstall the firmware /I payed for virtual dj onfinity and bought that rzx recently /sometimes when you load a track to virtual dj is kkind of freeze and you cant even play the sound you have to restart the virtual dj but my main issue is most of the time there is no sound playing on my headphone neither speakers i can see the signal meter on virtual dj showing the song is playing but there is no output audio at all on speakers or headphone / i even change usb port I am having the same issue / on virtual dj program itself it shows master and hedphone setting as 48.0k 5ms 10o/10i so i went to windows audio control panel (windows sound setting) which we have playback and recording on playbnback tab i got Line (pioneer dj ddjrzx) than i got nvidia high definatioan audio output and i also got speakers reltek since the setting on virtual dj itself it was 48.0k 5ms 10o/10i /first my default sound on windows ausio setting on playback and recording both set to line (ddjrzx) so you can say windows audio is disable while i am hooking up the rzx and default is set to line /than i left click on the line properties i went to advance tab iand i changed the setting bitrate there to : 2 channel 32bit 4800 hz and also on sound recording tab which the default is line(rzx) i did right click on ythe mouse peroperties and on advance tab i set it again to 2 channel 32bit 4800 hz what am i doing wrong ?? is the a mapping issue how can i fix that issue it seems one guy on youtube have a same issue also but i am not sure if he iusing virtual dj here is the video of the same guy who might have a similar issue as me https://www.youtube.com/watch?v=divq7AjuMTc everyone i need your help i dont have sound and i can not use virtual dj with ddjrzx btw on ddjrzx controller itself i can see the signal meter and on both screen also showing the songs are playing i am just curious on windows audio setting control panel the defaut should be rzx line or reltek ?

Posted Fri 03 Jan 20 @ 9:24 pm
I sometimes get the no sound issue on my RZX but if I go into sound settings in VDJ and change the samplerate to 96, it then works. I dont know why this happens as its set at 48 in the asio panel and in Rekordbox, but thats my work around.

Posted Sat 04 Jan 20 @ 11:44 am
djt88PRO InfinityMember since 2017
DJ-BONGO1 wrote :
I sometimes get the no sound issue on my RZX but if I go into sound settings in VDJ and change the samplerate to 96, it then works. I dont know why this happens as its set at 48 in the asio panel and in Rekordbox, but thats my work around.


can you explain how and where you change the samplerate on virtual dj ?

Posted Sat 04 Jan 20 @ 2:00 pm

Posted Sat 04 Jan 20 @ 4:21 pm
djt88PRO InfinityMember since 2017

Posted Sat 04 Jan 20 @ 4:27 pm
You asked where to change the setting. That page of the manual shows you.

It should be obvious anyway. Settings are changed by clicking config in VDJ (if you don't know where that is, read the manual).

Find the exact setting by using the search option at the top of the window (as shown in the manual).


Posted Sat 04 Jan 20 @ 5:05 pm
djt88PRO InfinityMember since 2017
groovindj wrote :
You asked where to change the setting. That page of the manual shows you.

It should be obvious anyway. Settings are changed by clicking config in VDJ (if you don't know where that is, read the manual).

Find the exact setting by using the search option at the top of the window (as shown in the manual).



thanks i think is in options and you search for samplesrate and you change it there some peoples have it as 4410 some 4800

Posted Sat 04 Jan 20 @ 5:24 pm
djt88PRO InfinityMember since 2017
DJ-BONGO1 wrote :
I sometimes get the no sound issue on my RZX but if I go into sound settings in VDJ and change the samplerate to 96, it then works. I dont know why this happens as its set at 48 in the asio panel and in Rekordbox, but thats my work around.


bro i change the sample rate on virtual dj and windows sound setting itself to 96.ok somehow is working now thanks

Posted Sat 04 Jan 20 @ 6:09 pm
Even with a saved config it seems to revert back, but at least you know where to look next time.

Posted Sat 04 Jan 20 @ 10:26 pm
djt88PRO InfinityMember since 2017
DJ-BONGO1 wrote :
Even with a saved config it seems to revert back, but at least you know where to look next time.


i am agree with you i dont know what the heck is that sometimes audio playback sometimes there is not sometimes sometimes when you reboot same issue sometimes is work on 4100 sometimes 4800 or 9600 you have to change all sound setting in windows and vdj same samplerate pioneer asio itself need to be set to internal they should update the mapping

Posted Sun 05 Jan 20 @ 12:43 am

Posted Mon 15 Jun 20 @ 12:41 pm

Posted Mon 15 Jun 20 @ 1:29 pm
This helps until the next audio error, then you need to change it again. This also happens with the rekordbox software, so this is an ASIO or USB driver issue with DDJ-RZX. Pioneer has got an bug report alrerady 1 year ago, but nothing happens.

Posted Tue 23 Jun 20 @ 9:15 pm
I have the same problem. After fighting with this for many hours, I think I found something that works:

If I enable the VDJ audio option "Exclusive Audio Access" and set the VDJ performance bitrate option to "Automatic" then all works great reboot after reboot, startup after startup. However, VDJ will always be in 44100 mode. If I change the VDJ bitrate to 48000 or 96000, it works for the moment. However then the problem is back after rebooting/restarting VDJ - no sound until I go into the VDJ performance settings and diddle the bitrate.

Anyway, this solves the problem for me now. I can live with 44100 instead of 48000. However, it definitely seems like VDJ has a problem with setting the bitrate during startup as only the driver default of 44100 works right away when starting VDJ... Clearly VDJ is able to set the bitrate as manually changing it works fine - it just seems that it does it differently during startup since it does not work then and you have to go manually and dial in 48000 or 96000.

Posted Wed 09 Sep 20 @ 5:52 pm
VDJ Monty wrote :
This also happens with the rekordbox software, so this is an ASIO or USB driver issue with DDJ-RZX.


Bingo! The problem is that the USB driver always defaults to 44100 sample rate and the DJ Software has to change it.

I found out that if I set the bitrate to 44100 both Virtual DJ and Rekorbox work FLAWLESSLY.
If I set it to 48000 or 96000 both Virtual DJ and Rekorbox have intermittent problems with no sound on startup.

Arguably this is a design flaw with the DDJ-RZX driver. Virtual DJ tech support advises that the sample rate should always be set in the driver and that Virtual DJ should be left in "Automatic" mode. The sad thing is that I don't see a way to set the sample rate in the DDJ-RZX driver. Adding an option in the "DDJ RZX Setting Utility" to do this would be very much welcome and would provide the ultimate solution for the problem we're experiencing in both Rekordbox and VirtualDJ.

Posted 5 days ago @ 5:02 pm
Send me you email address by PM, i will send you the new beta firmware 1.11
My RZX is running rock stable now.

Posted 5 days ago @ 9:07 pm