Forum: General Discussion

About VirtualDJ and DJing in general

If you need extended support, contact our Support Team.
Forum Guidelines  (*) The moderators hold the rights to remove, move or modify posts.
Topic: Pioneer DDJ SX3 Line In 4 Problem
Just recently purchased a DDJ SX3 and have it working properly with Virtual DJ. I do have a problem with line 4, the selection switch is set to "line" and it works as expected until Virtual DJ is started, then the channel does not send to the master. It will cue to the headphones, it appears the fader is not operating. This was not a problem on the original DDJ SX.

Does anyone have any suggestions?

Kevin

Posted Sun 06 Jan 19 @ 10:12 pm
djdadPRO InfinityDevelopment ManagerMember since 2005
So the auxiliary source (whatever you have connected to the Input Channel 3 ) stops playing at Master when VDJ starts. If you switch to another Source and then back to LINE, does the sound comes back ?
Please make sure ..
- you have the Audio Setup exactly as per the Manual http://www.virtualdj.com/manuals/hardware/pioneer/ddjsx3/setup.html
- You are using the "factory" default mapping.

Posted Mon 07 Jan 19 @ 1:53 pm
That is correct. It does not help If I switch to another source and back. It does cue to the headphones so it seems virtual DJ is taking control of the channel 4 fader. I have setup as per the manual and can confirm I’m using the factory default mapping.

Posted Sun 27 Jan 19 @ 1:15 am
Went over the setup again and I think I got it. Everything seems to work but the fillter knobs. Any suggestions on that one?

Posted Sun 27 Jan 19 @ 1:49 am
I continue to struggle with this. I have got it so that the line in work most of the time (Thanks DJ Dad). But that has caused a bigger issue. When the line in is active, the BPM sync wants to sync to line line in (deck 4) and ignores the BPM value on either deck 1 or deck 2. When there is no audio present on the line in the BPM defaults to 120 BPM (This really messed me up at my last gig), and deck 1 and 2 sync only to 120 BPM. Is there a way to either disable the BPM on line in or have Virtual DJ ignore this value and allow syncing between deck 1 and 2.?

Posted Sat 02 Feb 19 @ 7:06 pm
AdionPRO InfinityCTOMember since 2006
Turn the volume down when not playing through the line in

Posted Sun 03 Feb 19 @ 4:22 am
Thanks Adion, I have tried turning the fader down and it works for beat syncing deck one and two but tools like the sampler and ShowXpress (DMX control) are still getting their BPM from either input 3 or input 4 (when no audio is present on deck 1 or 2), even when the fader is down. This may be coming from input 3 which is always set to mic and the fader left up (use switch on mic). The new mapping fro my DDJSX3 has messed things up compared to my DDJSX1.

Posted Sun 03 Feb 19 @ 3:45 pm
Does someone solved the bpm issue for the DDJ-SX3? This is a big bug, overall when you use effects to mix songs with irregular bmp! When you stop the song you want to mix, the new song try to sync with mic or line channel, causing a big mistake!! Is there a solution?

Posted Mon 10 Feb 20 @ 4:24 pm