Forum: VirtualDJ 8.2 Technical Support

Use this forum to report any bug, questions or comment related to the latest version of VirtualDJ 8.2.
Forum Guidelines

(NOTE: VirtualDJ 8.2 is continuously updated, so many older topic on this forum are most probably already fixed in the current build)
Topic: b4064 bug - Page: 1
Just wanted to give a little feedback about transitions with automix editor and real time transition with the crossfader is not correct, difficult to explain, but sometimes when I go into the automix editor to watch the transition in real time, the crossfader does not move when the blue area is reached and played. Have not tested so much yet, just wanted to write down this thing just when I saw it now. You can also see it in the screenshot.


Posted Fri 12 Jan 18 @ 9:24 pm
not a bug. the crossfader shouldn't move if on single deck automix

Posted Fri 12 Jan 18 @ 11:05 pm
Yeah, sure. But this is dual deck automix. It happens not all the time, mostly from channel 1 to channel 2. Not sure if it ever happens from channel 2 to 1. I will test some more.

Posted Sat 13 Jan 18 @ 4:51 am
Seems it happens more often when I zoom in to the next transition right before it starts, and the red pointer-line has even jumped over the whole blue transition area before it has reached the fading-area in the top waveform. I can possibly make a short screen-recording if the staff has problem recognizing this bug. A lot of work to set up and get screen recorder to work here, so just give me a hint if this is neccacary for troubleshooting.

Posted Sat 13 Jan 18 @ 4:59 am








This is 3 screenshots taken during a transition. You can see on the first picture that the white pointer-line on the blue channel 1 waveform has not reached the transition, but in automix editor it is already showing it is finished. And on the third picture, the pointer-line on automix editor jumped back to where it belong just the moment the transition was finished.

Posted Sat 13 Jan 18 @ 5:10 am
What is your crossfader curve set at?

Posted Sat 13 Jan 18 @ 5:58 am






It is set to full in my options, but strange nothing is listed in the main window... I will test some more around this.

Posted Sat 13 Jan 18 @ 6:53 am
It looks like it's set to 0.511811. What do you want it to be?

Posted Sat 13 Jan 18 @ 6:56 am
Wow, just set my options to full again, and now the whole program took a total reset right after the next transition... took screenshot right before and after... It even loaded an old automix playlist I had yesterday :p





I am starting to suspect my MC6000mk2 is doing strange things... I will try my other psu, I bought a 4A which I never have tested (3A is original but I lost my original so I had to buy a new, and have both 3A and 4A) . Will update after testing.

Posted Sat 13 Jan 18 @ 7:02 am
A Man and His Music wrote :
It looks like it's set to 0.511811. What do you want it to be?


5.11811 is what the settings are set to when options are saved as "full". I understand this should be correct. Correct me if I am wrong.

Posted Sat 13 Jan 18 @ 7:05 am
RoninSaniShipibo wrote :

I am starting to suspect my MC6000mk2 is doing strange things... I will try my other psu, I bought a 4A which I never have tested (3A is original but I lost my original so I had to buy a new, and have both 3A and 4A) . Will update after testing.


No the plug didn't fit... was a bit smaller. I don't think I should cut and solder these... could maybe fry my controller. Jajaja... I am now planning for real to save some money and buy a new computer... My old Asus M5A97 r2 is probably singing its last verse... But this last chop-up came the same moment as the automix transition was over, so I am pretty sure it was something about VirtualDj this time. And even loaded a playlist I had yesterday, after many adjustments in my new list.

Posted Sat 13 Jan 18 @ 7:13 am
I don't know, Mine says what ever I select.

Posted Sat 13 Jan 18 @ 8:17 am
A Man and His Music wrote :
I don't know, Mine says what ever I select.


Yes here too, but when I quit virtualdj and start it up again, the numbers is there.

Posted Sat 13 Jan 18 @ 9:05 am
AdionPRO InfinityCTOMember since 2006
If your controller has a crossfadercurve knob it is normal that it may not be perfectly centered, and therefore not be exactly at Full (0.5) but slightly off.

Posted Sat 13 Jan 18 @ 10:40 am
Yes, thanks for info, that would be the case for the numbers, there is off course a crossfader slider on my Denon MC600mk2. But that was just a thing "A Man and His Music" was mentioning, not actually relevant in the bug I am reporting in this thread. I have been using automix a lot lately, and have never seen this before. I could roll back a version and test, but I don't think it would be neccacary as this is a very clearly bug I can recreate any time. It would be more interesting if nobody else or the staff were unable to recreate the bug. I will wait for an answer or a new version.

Posted Sat 13 Jan 18 @ 3:21 pm
This bug is still there. just saying.

Posted Mon 12 Feb 18 @ 4:33 am
Looks like automix is getting wrong datas from the playlist.

Posted Mon 12 Feb 18 @ 4:34 am
Any tip of how many versions I have to roll back to get rid of this bug? Seems like the last version 4064 is going to stay for a while...

Posted Mon 12 Feb 18 @ 4:39 am
RoninSaniShipibo wrote :
This bug is still there. just saying.


The builds don't change, so if you use the same build there is no change

Posted Mon 12 Feb 18 @ 6:23 am
RoninSaniShipibo wrote :
Any tip of how many versions I have to roll back to get rid of this bug?

I haven't tried it myself, but first step could be to go back to the latest public release which is b3994
b4064 is an Early Access release

RoninSaniShipibo wrote :
Seems like the last version 4064 is going to stay for a while...

If you by "a while" mean days, then maybe
If you mean months, then not likely, if you look at recent release history
But looking at the thread I'm not sure the issue has been recognized as a bug, which may mean that nobody is looking at it right now, so going back may be you best bet for now

Posted Mon 12 Feb 18 @ 6:27 am
Page : [>] [>>]
83%